summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2018-08-02 16:23:11 +0200
committerLeo Famulari <leo@famulari.name>2018-08-16 18:36:09 -0400
commite0b49c785b6fe577fbf07e5d74b8544e9d336209 (patch)
treea4eb5271f0e5e7e86a35603e9a520007e129716f /gnu/packages/scheme.scm
parent41c038078e795005420012c173725d06c7e23256 (diff)
downloadguix-patches-e0b49c785b6fe577fbf07e5d74b8544e9d336209.tar
guix-patches-e0b49c785b6fe577fbf07e5d74b8544e9d336209.tar.gz
gnu: racket: Update to 7.0.
* gnu/packages/scheme.scm (racket): Update to 7.0. [inputs]: Add libedit. [arguments]: Update the list of FFI library references to patch. [source]: Remove 'racket-fix-xform-issue.patch'. * gnu/packages/patches/racket-store-checksum-override.patch: Adjust. * gnu/packages/patches/racket-fix-xform-issue.patch: Delete file. * gnu/local.mk: Adjust accordingly. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm39
1 files changed, 20 insertions, 19 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index b30245ccea..1e045a27fd 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -65,6 +65,7 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages tls)
#:use-module (gnu packages gl)
+ #:use-module (gnu packages libedit)
#:use-module (ice-9 match))
(define (mit-scheme-source-directory system version)
@@ -407,22 +408,19 @@ implementation techniques and as an expository tool.")
(define-public racket
(package
(name "racket")
- (version "6.12")
+ (version "7.0")
(source (origin
- (method url-fetch)
- (uri (list (string-append "http://mirror.racket-lang.org/installers/"
- version "/racket-" version "-src.tgz")
- (string-append
- "http://mirror.informatik.uni-tuebingen.de/mirror/racket/"
- version "/racket-" version "-src.tgz")))
- (sha256
- (base32
- "0cwcypzjfl9py1s695mhqkiapff7c1w29llsmdj7qgn58wl0apk5"))
- (patches (search-patches
- ;; See: https://github.com/racket/racket/issues/1962
- ;; This can be removed in whatever Racket release comes after 6.12
- "racket-fix-xform-issue.patch"
- "racket-store-checksum-override.patch"))))
+ (method url-fetch)
+ (uri (list (string-append "http://mirror.racket-lang.org/installers/"
+ version "/racket-" version "-src.tgz")
+ (string-append
+ "http://mirror.informatik.uni-tuebingen.de/mirror/racket/"
+ version "/racket-" version "-src.tgz")))
+ (sha256
+ (base32
+ "1glv5amsp9xp480d4yr63hhm9kkyav06yl3a6p489nkr4cln0j9a"))
+ (patches (search-patches
+ "racket-store-checksum-override.patch"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -485,7 +483,9 @@ implementation techniques and as an expository tool.")
("share/pkgs/gui-lib/mred/private/wx/gtk/gl-context.rkt"
("libGL"))
("share/pkgs/sgl/gl.rkt"
- ("libGL" "libGLU")))))
+ ("libGL" "libGLU"))
+ ("share/pkgs/readline-lib/readline/rktrl.rkt"
+ ("libedit")))))
(chdir "src")
#t))
(add-after 'unpack 'patch-/bin/sh
@@ -493,7 +493,7 @@ implementation techniques and as an expository tool.")
(substitute* "collects/racket/system.rkt"
(("/bin/sh") (which "sh")))
#t)))
- #:tests? #f ; XXX: how to run them?
+ #:tests? #f ; XXX: how to run them?
))
(inputs
`(("libffi" ,libffi)
@@ -504,7 +504,7 @@ implementation techniques and as an expository tool.")
("glib" ,glib)
("glu" ,glu)
("gmp" ,gmp)
- ("gtk+" ,gtk+) ; propagates gdk-pixbuf+svg
+ ("gtk+" ,gtk+) ; propagates gdk-pixbuf+svg
("libjpeg" ,libjpeg)
("libpng" ,libpng)
("libx11" ,libx11)
@@ -513,7 +513,8 @@ implementation techniques and as an expository tool.")
("openssl" ,openssl)
("pango" ,pango)
("sqlite" ,sqlite)
- ("unixodbc" ,unixodbc)))
+ ("unixodbc" ,unixodbc)
+ ("libedit" ,libedit)))
(home-page "http://racket-lang.org")
(synopsis "Implementation of Scheme and related languages")
(description