summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 16:37:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-27 12:46:29 +0200
commitb69819d8c25ac0e2989b54e998eaa63fa1ce80e0 (patch)
tree129fe205a0cdd481044263b975e469bd06ae1adc /gnu/packages/scheme.scm
parent24674e6141c089d8b4f1ece8cade44656853185d (diff)
downloadguix-patches-b69819d8c25ac0e2989b54e998eaa63fa1ce80e0.tar
guix-patches-b69819d8c25ac0e2989b54e998eaa63fa1ce80e0.tar.gz
gnu: scmutils: Return #t from all phases.
* gnu/packages/scheme.scm (scmutils)[arguments]: Substitute INVOKE for SYSTEM*. Return #t rather than undefined or #f from phases.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index ddc4014d7f..4d5c835454 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -660,7 +660,8 @@ threads.")
"| mit-scheme")))
(with-directory-excursion "scmutils/scmutils"
(and (zero? (system "mit-scheme < compile.scm"))
- (zero? (system make-img)))))))
+ (zero? (system make-img))))
+ #t)))
(add-before 'install 'fix-directory-names
;; Correct directory names in the startup script.
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -684,8 +685,8 @@ threads.")
;; code.
(lambda* (#:key inputs outputs #:allow-other-keys)
(with-directory-excursion "scmutils/scmutils"
- (zero? (apply system* "etags"
- (find-files "." "\\.scm"))))))
+ (apply invoke "etags" (find-files "." "\\.scm")))
+ #t))
(replace 'install
;; Copy files to the store.
(lambda* (#:key outputs #:allow-other-keys)