summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 17:42:41 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-27 12:46:30 +0200
commitb44b14cd85b2962bc3062c6da59a83deacb0de13 (patch)
tree17d23256c4f45610176843b53462104280dd128f /gnu/packages/scheme.scm
parent2e14ca198230878405a00d4351e5424a7b964a22 (diff)
downloadguix-patches-b44b14cd85b2962bc3062c6da59a83deacb0de13.tar
guix-patches-b44b14cd85b2962bc3062c6da59a83deacb0de13.tar.gz
gnu: scm: Return #t from phases.
* gnu/packages/scheme.scm (scm)[arguments]: Substitute INVOKE for SYSTEM*. Return #t rather than undefined from phases.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm39
1 files changed, 17 insertions, 22 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index db39632f0c..4178a45a89 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -917,39 +917,34 @@ utility functions for all standard Scheme implementations.")
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
- (zero? (system* "./configure"
- (string-append "--prefix="
- (assoc-ref outputs "out"))))))
+ (invoke "./configure"
+ (string-append "--prefix="
+ (assoc-ref outputs "out")))))
(add-before 'build 'pre-build
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "Makefile"
- (("ginstall-info") "install-info"))))
+ (("ginstall-info") "install-info"))
+ #t))
(replace 'build
(lambda* (#:key inputs outputs #:allow-other-keys)
(setenv "SCHEME_LIBRARY_PATH"
(string-append (assoc-ref inputs "slib")
"/lib/slib/"))
- (and
- (zero? (system* "make" "scmlit" "CC=gcc"))
- (zero? (system* "make" "all")))))
+ (invoke "make" "scmlit" "CC=gcc")
+ (invoke "make" "all")))
(add-after 'install 'post-install
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((req
- (string-append (assoc-ref outputs "out")
- "/lib/scm/require.scm")))
- (and
- (delete-file req)
- (format (open req (logior O_WRONLY O_CREAT))
- "(define (library-vicinity) ~s)\n"
- (string-append (assoc-ref inputs "slib")
- "/lib/slib/"))
+ (let* ((out (assoc-ref outputs "out"))
+ (req (string-append out "/lib/scm/require.scm")))
+ (delete-file req)
+ (format (open req (logior O_WRONLY O_CREAT))
+ "(define (library-vicinity) ~s)\n"
+ (string-append (assoc-ref inputs "slib")
+ "/lib/slib/"))
- ;; We must generate the slibcat file
- (zero? (system*
- (string-append
- (assoc-ref outputs "out")
- "/bin/scm")
- "-br" "new-catalog")))))))))
+ ;; We must generate the slibcat file.
+ (invoke (string-append out "/bin/scm")
+ "-br" "new-catalog")))))))
(inputs `(("slib" ,slib)))
(native-inputs `(("unzip" ,unzip)
("texinfo" ,texinfo)))