summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2018-03-18 14:41:04 -0500
committerChristopher Lemmer Webber <cwebber@dustycloud.org>2018-04-02 10:38:08 -0500
commit75afbd247876d62f27cb2c90098bd59040f7e614 (patch)
tree5bd8525212c4035e66db2ff16b286cf835770b6d /gnu/packages/scheme.scm
parent02283a61304205244dde9c2c648372960cd2e493 (diff)
downloadguix-patches-75afbd247876d62f27cb2c90098bd59040f7e614.tar
guix-patches-75afbd247876d62f27cb2c90098bd59040f7e614.tar.gz
gnu: racket: Patch xform compilation errors.
* gnu/packages/patches/gnu/packages/patches/racket-fix-xform-issue.patch: Renamed from gnu/packages/patches/racket-minus_zero_p-disable-xform.patch. Switch to upstream patch in Racket. * gnu/packages/scheme.scm (racket): Update to renamed patch.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index d89b123f1d..c9e1a15255 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -418,7 +418,8 @@ implementation techniques and as an expository tool.")
"0cwcypzjfl9py1s695mhqkiapff7c1w29llsmdj7qgn58wl0apk5"))
(patches (search-patches
;; See: https://github.com/racket/racket/issues/1962
- "racket-minus_zero_p-disable-xform.patch"))))
+ ;; This can be removed in whatever Racket release comes after 6.12
+ "racket-fix-xform-issue.patch"))))
(build-system gnu-build-system)
(arguments
'(#:phases