summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 23:10:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 23:11:21 +0100
commit723f332551c336790e6fd628e4418f5be2eb42c0 (patch)
tree28a1f0138f819ba3de1b6e77931dc57db532c0c3 /gnu/packages/scheme.scm
parentdd7bc92afcd4b69849fc55041ac0261315cde2da (diff)
downloadguix-patches-723f332551c336790e6fd628e4418f5be2eb42c0.tar
guix-patches-723f332551c336790e6fd628e4418f5be2eb42c0.tar.gz
gnu: femtolisp: Use INVOKE.
* gnu/packages/scheme.scm (femtolisp)[arguments]: Remove "bootstrap" phase; use INVOKE and return #T unconditionally.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index b836447668..bcaccb452c 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1147,6 +1147,7 @@ generation.")
#:test-target "test"
#:phases
(modify-phases %standard-phases
+ (delete 'bootstrap)
(delete 'configure) ; No configure script
(replace 'install ; Makefile has no 'install phase
(lambda* (#:key outputs #:allow-other-keys)
@@ -1160,9 +1161,9 @@ generation.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin")))
- (and
- (zero? (system* "./bootstrap.sh"))
- (install-file "flisp.boot" bin))))))))
+ (invoke "./bootstrap.sh")
+ (install-file "flisp.boot" bin)
+ #t))))))
(synopsis "Scheme-like lisp implementation")
(description
"@code{femtolisp} is a scheme-like lisp implementation with a