summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-01-17 08:24:30 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-01-17 08:24:30 +0100
commit6c4a951a6e8f63c683dd7aca0651cd482ee2f3d3 (patch)
tree8fecc823aae670e9b3d334b0f13c7c11505559a9 /gnu/packages/scheme.scm
parent2615ee95204fbd5cbc73d236ecbd24a4fbdc5de5 (diff)
downloadguix-patches-6c4a951a6e8f63c683dd7aca0651cd482ee2f3d3.tar
guix-patches-6c4a951a6e8f63c683dd7aca0651cd482ee2f3d3.tar.gz
gnu: gauche: Remove number of packages from description.
* gnu/packages/scheme.scm (gauche)[description]: Remove number of packages. [arguments]: Remove useless code.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 4f61bd1667..b836447668 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1214,13 +1214,9 @@ The core is 12 builtin special forms and 33 builtin functions.")
(("/bin/sh") (which "sh")))
#t))
(add-after 'build 'build-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
- (with-directory-excursion "doc"
- (for-each
- (lambda (target)
- (invoke "make" target))
- '("info" "html" "htmls"))))
+ (lambda _
+ (with-directory-excursion "doc"
+ (invoke "make" "info"))
#t))
(add-before 'check 'patch-normalize-test
;; neutralize sys-normalize-pathname test as it relies on
@@ -1236,10 +1232,9 @@ The core is 12 builtin special forms and 33 builtin functions.")
(("binary net termios") "binary termios"))
#t))
(add-after 'install 'install-docs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
- (with-directory-excursion "doc"
- (invoke "make" "install")))
+ (lambda _
+ (with-directory-excursion "doc"
+ (invoke "make" "install"))
#t)))))
(synopsis "Scheme scripting engine")
(description "Gauche is a R7RS Scheme scripting engine aiming at being a
@@ -1247,6 +1242,5 @@ handy tool that helps programmers and system administrators to write small to
large scripts quickly. Quick startup, built-in system interface, native
multilingual support are some of the goals. Gauche comes with a package
manager/installer @code{gauche-package} which can download, compile, install
-and list gauche extension packages. There are currently 58 packages
-available.")
+and list gauche extension packages.")
(license bsd-3)))