summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2017-12-24 13:59:38 -0500
committerKei Kebreau <kkebreau@posteo.net>2017-12-24 14:02:06 -0500
commit595b175103ce74e5bc288a5ec3734e62b82a9403 (patch)
tree23c5843d0a0d3233fb90f3bdeb87bc65bc7990a1 /gnu/packages/scheme.scm
parentb982fb1c09573f4638324d7809ec18d0c9956d11 (diff)
downloadguix-patches-595b175103ce74e5bc288a5ec3734e62b82a9403.tar
guix-patches-595b175103ce74e5bc288a5ec3734e62b82a9403.tar.gz
gnu: scmutils: Update to 20160827.
* gnu/packages/scheme.scm (scmutils): Update to 20160827. [arguments]: Fix indentation.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm188
1 files changed, 94 insertions, 94 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 36e1bd6769..a20a0235f4 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -599,7 +599,7 @@ threads.")
(package
(name "scmutils")
- (version "20140302")
+ (version "20160827")
(source
(origin
(method url-fetch/tarbomb)
@@ -611,7 +611,7 @@ threads.")
"/scmutils-tarballs/" name "-" version
"-x86-64-gnu-linux.tar.gz"))
(sha256
- (base32 "10cnbm7nh78m5mrl1di85s29gny81jb1am9zd9f9yx725xb6dnfg"))))
+ (base32 "00ly5m0s4dy5kxravjaqlpii5zcnr6b9nqm0607lr7xcs52i4j8b"))))
(build-system gnu-build-system)
(inputs
`(("mit-scheme" ,mit-scheme)
@@ -626,104 +626,104 @@ threads.")
#:phases
(modify-phases %standard-phases
(replace 'configure
- ;; No standard build procedure is used. We set the correct
- ;; runtime path in the custom build system.
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; Required to find .bci files at runtime.
- (with-directory-excursion "scmutils"
- (rename-file "src" "scmutils"))
- (substitute* "scmutils/scmutils/load.scm"
- (("/usr/local/scmutils/")
- (string-append out "/lib/mit-scheme-"
- ,(system-suffix) "/")))
- #t)))
+ ;; No standard build procedure is used. We set the correct
+ ;; runtime path in the custom build system.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; Required to find .bci files at runtime.
+ (with-directory-excursion "scmutils"
+ (rename-file "src" "scmutils"))
+ (substitute* "scmutils/scmutils/load.scm"
+ (("/usr/local/scmutils/")
+ (string-append out "/lib/mit-scheme-"
+ ,(system-suffix) "/")))
+ #t)))
(replace 'build
- ;; Compile the code and build a band.
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (make-img (string-append
- "echo '(load \"load\") "
- "(disk-save \"edwin-mechanics.com\")'"
- "| mit-scheme")))
- (with-directory-excursion "scmutils/scmutils"
- (and (zero? (system "mit-scheme < compile.scm"))
- (zero? (system make-img)))))))
+ ;; Compile the code and build a band.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (make-img (string-append
+ "echo '(load \"load\") "
+ "(disk-save \"edwin-mechanics.com\")'"
+ "| mit-scheme")))
+ (with-directory-excursion "scmutils/scmutils"
+ (and (zero? (system "mit-scheme < compile.scm"))
+ (zero? (system make-img)))))))
(add-before 'install 'fix-directory-names
- ;; Correct directory names in the startup script.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (scm-root (assoc-ref inputs "mit-scheme")))
- (substitute* "bin/mechanics"
- (("ROOT=\"\\$\\{SCMUTILS_ROOT:-/.*\\}\"")
- (string-append
- "ROOT=\"${SCMUTILS_ROOT:-" scm-root "}\"\n"
- "LIB=\"${ROOT}/lib/mit-scheme-"
- ,(system-suffix) ":"
- out "/lib/mit-scheme-" ,(system-suffix) "\""))
- (("EDWIN_INFO_DIRECTORY=.*\n") "")
- (("SCHEME=.*\n")
- (string-append "SCHEME=\"${ROOT}/bin/scheme "
- "--library ${LIB}\"\n"))
- (("export EDWIN_INFO_DIRECTORY") ""))
- #t)))
+ ;; Correct directory names in the startup script.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (scm-root (assoc-ref inputs "mit-scheme")))
+ (substitute* "bin/mechanics"
+ (("ROOT=\"\\$\\{SCMUTILS_ROOT:-/.*\\}\"")
+ (string-append
+ "ROOT=\"${SCMUTILS_ROOT:-" scm-root "}\"\n"
+ "LIB=\"${ROOT}/lib/mit-scheme-"
+ ,(system-suffix) ":"
+ out "/lib/mit-scheme-" ,(system-suffix) "\""))
+ (("EDWIN_INFO_DIRECTORY=.*\n") "")
+ (("SCHEME=.*\n")
+ (string-append "SCHEME=\"${ROOT}/bin/scheme "
+ "--library ${LIB}\"\n"))
+ (("export EDWIN_INFO_DIRECTORY") ""))
+ #t)))
(add-before 'install 'emacs-tags
- ;; Generate Emacs's tags for easy reference to source
- ;; code.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (with-directory-excursion "scmutils/scmutils"
- (zero? (apply system* "etags"
- (find-files "." "\\.scm"))))))
+ ;; Generate Emacs's tags for easy reference to source
+ ;; code.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (with-directory-excursion "scmutils/scmutils"
+ (zero? (apply system* "etags"
+ (find-files "." "\\.scm"))))))
(replace 'install
- ;; Copy files to the store.
- (lambda* (#:key outputs #:allow-other-keys)
- (define* (copy-files-to-directory files dir
- #:optional (delete? #f))
- (for-each (lambda (f)
- (copy-file f (string-append dir "/" f))
- (when delete? (delete-file f)))
- files))
+ ;; Copy files to the store.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (define* (copy-files-to-directory files dir
+ #:optional (delete? #f))
+ (for-each (lambda (f)
+ (copy-file f (string-append dir "/" f))
+ (when delete? (delete-file f)))
+ files))
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (doc (string-append out "/share/doc/"
- ,name "-" ,version))
- (lib (string-append out "/lib/mit-scheme-"
- ,(system-suffix)
- "/scmutils")))
- (for-each mkdir-p (list lib doc bin))
- (with-directory-excursion "scmutils/scmutils"
- (copy-files-to-directory '("COPYING" "LICENSE")
- doc #t)
- (for-each delete-file (find-files "." "\\.bin"))
- (copy-files-to-directory '("edwin-mechanics.com")
- (string-append lib "/..") #t)
- (copy-recursively "." lib))
- (with-directory-excursion "bin"
- (copy-files-to-directory (find-files ".") bin))
- (with-directory-excursion "scmutils/manual"
- (copy-files-to-directory (find-files ".") doc))
- #t)))
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (doc (string-append out "/share/doc/"
+ ,name "-" ,version))
+ (lib (string-append out "/lib/mit-scheme-"
+ ,(system-suffix)
+ "/scmutils")))
+ (for-each mkdir-p (list lib doc bin))
+ (with-directory-excursion "scmutils/scmutils"
+ (copy-files-to-directory '("COPYING" "LICENSE")
+ doc #t)
+ (for-each delete-file (find-files "." "\\.bin"))
+ (copy-files-to-directory '("edwin-mechanics.com")
+ (string-append lib "/..") #t)
+ (copy-recursively "." lib))
+ (with-directory-excursion "bin"
+ (copy-files-to-directory (find-files ".") bin))
+ (with-directory-excursion "scmutils/manual"
+ (copy-files-to-directory (find-files ".") doc))
+ #t)))
(add-after 'install 'emacs-helpers
- ;; Add convenience Emacs commands to easily load the
- ;; Scmutils band in an MIT-Scheme buffer inside of Emacs
- ;; and to easily load code tags.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (mit-root (assoc-ref inputs "mit-scheme"))
- (emacs-lisp-dir
- (string-append out "/share/emacs/site-lisp"
- "/guix.d/" ,name "-" ,version))
- (el-file (string-append emacs-lisp-dir
- "/scmutils.el"))
- (lib-relative-path
- (string-append "/lib/mit-scheme-"
- ,(system-suffix))))
- (mkdir-p emacs-lisp-dir)
- (call-with-output-file el-file
- (lambda (p)
- (format p
- ";;;###autoload
+ ;; Add convenience Emacs commands to easily load the
+ ;; Scmutils band in an MIT-Scheme buffer inside of Emacs
+ ;; and to easily load code tags.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (mit-root (assoc-ref inputs "mit-scheme"))
+ (emacs-lisp-dir
+ (string-append out "/share/emacs/site-lisp"
+ "/guix.d/" ,name "-" ,version))
+ (el-file (string-append emacs-lisp-dir
+ "/scmutils.el"))
+ (lib-relative-path
+ (string-append "/lib/mit-scheme-"
+ ,(system-suffix))))
+ (mkdir-p emacs-lisp-dir)
+ (call-with-output-file el-file
+ (lambda (p)
+ (format p
+ ";;;###autoload
(defun scmutils-load ()
(interactive)
(require 'xscheme)