summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-13 23:39:52 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-13 23:45:53 -0500
commit01f0707207741ce2a5d7509a175464799b08aea6 (patch)
tree08e8f4da56f26363c3b53e0442a21b286b55e0e5 /gnu/packages/scheme.scm
parent734bcf13139119daf8685f93b056c3422dbfa264 (diff)
parent6985a1acb3e9cc4cad8b6f63d77154842d25c929 (diff)
downloadguix-patches-01f0707207741ce2a5d7509a175464799b08aea6.tar
guix-patches-01f0707207741ce2a5d7509a175464799b08aea6.tar.gz
Merge branch 'staging' into 'core-updates'.
Conflicts: gnu/local.mk gnu/packages/cmake.scm gnu/packages/curl.scm gnu/packages/gl.scm gnu/packages/glib.scm gnu/packages/guile.scm gnu/packages/node.scm gnu/packages/openldap.scm gnu/packages/package-management.scm gnu/packages/python-xyz.scm gnu/packages/python.scm gnu/packages/tls.scm gnu/packages/vpn.scm gnu/packages/xorg.scm
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm31
1 files changed, 13 insertions, 18 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index c01c5dfabd..a5a1793d3a 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015, 2016 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017 John Darrington <jmd@gnu.org>
@@ -1006,7 +1006,7 @@ The core is 12 builtin special forms and 33 builtin functions.")
(define-public gauche
(package
(name "gauche")
- (version "0.9.9")
+ (version "0.9.10")
(home-page "https://practical-scheme.net/gauche/index.html")
(source
(origin
@@ -1015,7 +1015,7 @@ The core is 12 builtin special forms and 33 builtin functions.")
"mirror://sourceforge/gauche/Gauche/Gauche-"
version ".tgz"))
(sha256
- (base32 "1yzpszhw52vkpr65r5d4khf3489mnnvnw58dd2wsvvx7499k5aac"))
+ (base32 "0ci57ak5cp3lkmfy3nh50hifh8nbg58hh6r18asq0rn5mqfxyf8g"))
(modules '((guix build utils)))
(snippet '(begin
;; Remove libatomic-ops.
@@ -1024,24 +1024,26 @@ The core is 12 builtin special forms and 33 builtin functions.")
(build-system gnu-build-system)
(inputs
`(("libatomic-ops" ,libatomic-ops)
+ ("slib" ,slib)
("zlib" ,zlib)))
(native-inputs
`(("texinfo" ,texinfo)
("openssl" ,openssl) ; needed for tests
("pkg-config" ,pkg-config))) ; needed to find external libatomic-ops
(arguments
- `(#:phases
+ `(#:configure-flags
+ (list (string-append "--with-slib="
+ (assoc-ref %build-inputs "slib")
+ "/lib/slib"))
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-/bin/sh
;; Needed only for tests.
(lambda _
- (substitute* '("configure"
- "test/www.scm"
+ (substitute* '("test/www.scm"
"ext/tls/test.scm"
- "gc/configure"
- "lib/gauche/configure.scm"
"lib/gauche/package/util.scm"
- "lib/gauche/process.scm")
+ "libsrc/gauche/process.scm")
(("/bin/sh") (which "sh")))
#t))
(add-after 'build 'build-doc
@@ -1049,18 +1051,11 @@ The core is 12 builtin special forms and 33 builtin functions.")
(with-directory-excursion "doc"
(invoke "make" "info"))
#t))
- (add-before 'check 'patch-normalize-test
- ;; Neutralize sys-normalize-pathname test as it relies on
- ;; the home directory; (setenv "HOME" xx) isn't enough).
- (lambda _
- (substitute* "test/system.scm"
- (("~/abc") "//abc"))
- #t))
(add-before 'check 'patch-network-tests
;; Remove net checks.
(lambda _
- (substitute* "ext/Makefile"
- (("binary net termios") "binary termios"))
+ (delete-file "ext/net/test.scm")
+ (invoke "touch" "ext/net/test.scm")
#t))
(add-after 'install 'install-docs
(lambda _