summaryrefslogtreecommitdiff
path: root/gnu/packages/scanner.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-07 01:34:18 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-07 02:13:26 +0100
commitabe6e670d356b8333b41c7359c0ab25a58fe736b (patch)
tree0f99d5ef342b64810b32d81817080fb428aeec28 /gnu/packages/scanner.scm
parentd40ec4a0d00df08ec4f866467080235f5a9fea87 (diff)
downloadguix-patches-abe6e670d356b8333b41c7359c0ab25a58fe736b.tar
guix-patches-abe6e670d356b8333b41c7359c0ab25a58fe736b.tar.gz
gnu: sane-backends-minimal: Fix USB support.
* gnu/packages/scanner.scm (sane-backends-minimal)[inputs]: Replace libusb-compat with libusb. [arguments]: Disable tests that require USB access.
Diffstat (limited to 'gnu/packages/scanner.scm')
-rw-r--r--gnu/packages/scanner.scm26
1 files changed, 17 insertions, 9 deletions
diff --git a/gnu/packages/scanner.scm b/gnu/packages/scanner.scm
index d030d8ade5..462727bc59 100644
--- a/gnu/packages/scanner.scm
+++ b/gnu/packages/scanner.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
@@ -55,7 +55,7 @@
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("libusb-compat" ,libusb-compat)))
+ `(("libusb" ,libusb)))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -63,19 +63,27 @@
(lambda _
(setenv "BACKENDS" " ")
#t))
- ;; Disable unmaintained tests that that fail with errors resembling:
- ;;
- ;; < # by sane-desc 3.5 from sane-backends 1.0.24git on Jul 31 2013
- ;; ---
- ;; > # by sane-desc 3.5 from sane-backends 1.0.27 on 1970-01-01#
- ;; FAIL: sane-desc -m usermap -s ./data
- (add-before 'configure 'disable-failing-tests
+ (add-after 'unpack 'disable-failing-tests
(lambda _
+ ;; Disable unmaintained tests that that fail with errors resembling:
+ ;;
+ ;; < # by sane-desc 3.5 from sane-backends 1.0.24git on Jul 31 2013
+ ;; ---
+ ;; > # by sane-desc 3.5 from sane-backends 1.0.27 on 1970-01-01#
+ ;; FAIL: sane-desc -m usermap -s ./data
(for-each
(lambda (pattern)
(substitute* "testsuite/tools/Makefile.in"
(((string-append " " pattern " ")) " ")))
(list "usermap" "db" "udev" "udev\\+acl" "udev\\+hwdb" "hwdb"))
+
+ ;; Disable tests that try to connect to actual USB hardware & fail
+ ;; with the following error when no USB access is allowed at all:
+ ;;
+ ;; sanei_usb_test: sanei_usb_test.c:849: main: Assertion
+ ;; `test_init (1)' failed.
+ (substitute* "testsuite/sanei/Makefile.in"
+ (("sanei_usb_test\\$\\(EXEEXT\\) ") ""))
#t))
(add-after 'install 'install-udev-rules
(lambda* (#:key outputs #:allow-other-keys)