summaryrefslogtreecommitdiff
path: root/gnu/packages/scanner.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-18 03:50:22 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-22 22:01:40 +0100
commita608666d74f156819cecfabaf72290726d7964e6 (patch)
treee316155a19e26e83846478c1aab920341a5b5dcd /gnu/packages/scanner.scm
parentee4db149c29b6d0fe6bcab552f163bbbe5b09738 (diff)
downloadguix-patches-a608666d74f156819cecfabaf72290726d7964e6.tar
guix-patches-a608666d74f156819cecfabaf72290726d7964e6.tar.gz
gnu: Add xsane.
* gnu/packages/scanner.scm (xsane): New public variable.
Diffstat (limited to 'gnu/packages/scanner.scm')
-rw-r--r--gnu/packages/scanner.scm88
1 files changed, 88 insertions, 0 deletions
diff --git a/gnu/packages/scanner.scm b/gnu/packages/scanner.scm
index b371cf3105..aa58b5aa50 100644
--- a/gnu/packages/scanner.scm
+++ b/gnu/packages/scanner.scm
@@ -21,11 +21,16 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages scanner)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages libusb)
#:use-module (gnu packages pkg-config)
#:use-module (guix build-system gnu)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module ((guix licenses)
#:prefix licence:)
#:use-module (guix packages)
@@ -148,3 +153,86 @@ package contains the library, but no drivers.")
proving access to any raster image scanner hardware (flatbed scanner,
hand-held scanner, video- and still-cameras, frame-grabbers, etc.). The
package contains the library and drivers.")))
+
+(define-public xsane
+ (package
+ (name "xsane")
+ (version "0.999")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/sane-project/frontend/xsane.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08zvxj7i1s88ckrsqldmsrikc3g62a6p3s3i5b5x4krcfpi3vs50"))
+ ;; Apply some important-looking fixes. There are many more unreleased
+ ;; commits upstream. A 1.0 release is planned.
+ (patches (search-patches "xsane-fix-memory-leak.patch"
+ "xsane-fix-pdf-floats.patch"
+ "xsane-support-ipv6.patch"
+ "xsane-tighten-default-umask.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove ancient bundled lprng code under a non-free licence. See
+ ;; <https://trisquel.info/en/issues/10713>, which solves the problem
+ ;; by replacing it with a newer (free) copy. We let the build fall
+ ;; back to the system version instead, which appears to work fine.
+ (delete-file "lib/snprintf.c")
+ (substitute* "lib/Makefile.in"
+ (("snprintf\\.o ") ""))
+ #t))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "xsanedocdir=" (assoc-ref %outputs "out")
+ "/share/doc/" ,name "-" ,version))
+ #:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-invalid-dereference
+ ;; Fix the following compilation error with libpng:
+ ;; xsane-save.c: In function ‘xsane_save_png’:
+ ;; xsane-save.c:4913:21: error: dereferencing pointer to
+ ;; incomplete type ‘png_struct {aka struct png_struct_def}’
+ ;; if (setjmp(png_ptr->jmpbuf))
+ ;; ^
+ (lambda _
+ (substitute* "src/xsane-save.c"
+ (("png_ptr->jmpbuf") "png_jmpbuf(png_ptr)"))
+ #t))
+ (add-after 'unpack 'use-sane-help-browser
+ (lambda _
+ (substitute* "src/xsane.h"
+ (("netscape") (which "xdg-open")))
+ #t))
+ (add-after 'install 'delete-empty-/sbin
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (rmdir (string-append out "/sbin"))
+ #t))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+" ,gtk+-2)
+ ("lcms" ,lcms)
+ ("libjpeg" ,libjpeg)
+ ("libtiff" ,libtiff)
+ ("sane-backends" ,sane-backends)
+
+ ;; To open the manual from the Help menu.
+ ("xdg-utils" ,xdg-utils)))
+ (home-page "https://gitlab.com/sane-project/frontend/xsane")
+ (synopsis "Featureful graphical interface for document and image scanners")
+ (description
+ "XSane is a graphical interface for controlling a scanner and acquiring
+images from it. You can photocopy multi-page documents and save, fax, print,
+or e-mail your scanned images. It is highly configurable and exposes all
+device settings, letting you fine-tune the final result. It can also be used
+as a GIMP plugin to acquire images directly from a scanner.
+
+XSane talks to scanners through the @acronym{SANE, Scanner Access Now Easy}
+back-end library, which supports almost all existing scanners.")
+ (license licence:gpl2+)))