summaryrefslogtreecommitdiff
path: root/gnu/packages/scanner.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-08-01 04:46:44 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-08-01 05:34:56 +0200
commit7018f926d4efcab681cca99e2da43b179d4af396 (patch)
treee922583645cf435937933675807bb4f337499676 /gnu/packages/scanner.scm
parent6af4cb30d30b7426e7c56a274f1a91cf15824559 (diff)
downloadguix-patches-7018f926d4efcab681cca99e2da43b179d4af396.tar
guix-patches-7018f926d4efcab681cca99e2da43b179d4af396.tar.gz
gnu: sane-backends-minimal: Update to 1.0.28.
* gnu/packages/scanner.scm (sane-backends-minimal): Update to 1.0.28. [arguments]: Disable back end tests.
Diffstat (limited to 'gnu/packages/scanner.scm')
-rw-r--r--gnu/packages/scanner.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/scanner.scm b/gnu/packages/scanner.scm
index d23da9e502..4afa90ba78 100644
--- a/gnu/packages/scanner.scm
+++ b/gnu/packages/scanner.scm
@@ -34,15 +34,16 @@
(define-public sane-backends-minimal
(package
(name "sane-backends-minimal")
- (version "1.0.27")
+ (version "1.0.28")
(source (origin
(method url-fetch)
(uri (string-append
- "https://alioth.debian.org/frs/download.php/latestfile/176/"
+ "https://gitlab.com/sane-project/backends/uploads/"
+ "9e718daff347826f4cfe21126c8d5091/"
"sane-backends-" version ".tar.gz"))
(sha256
(base32
- "1j9nbqspaj0rlgalafb5z6r606k0i22kz0rcpd744p176yzlfdr9"))
+ "00yy8q9hqdf0zjxxl4d8njr9zf0hhi3a9ib23ikc2anqf8zhy9ii"))
(modules '((guix build utils)))
(snippet
;; Generated HTML files and udev rules normally embed a
@@ -63,6 +64,10 @@
(add-before 'configure 'disable-backends
(lambda _
(setenv "BACKENDS" " ")
+
+ ;; Disable tests that may require back ends to be built.
+ (substitute* "testsuite/Makefile.in"
+ ((" backend ") " "))
#t))
(add-after 'unpack 'disable-failing-tests
(lambda _