summaryrefslogtreecommitdiff
path: root/gnu/packages/scanner.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-05-24 17:08:22 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-05-24 22:54:39 +0200
commit4ed390a0e7fc468303c07d6efebc54c80b2369c5 (patch)
tree82aed4b5d825353cb83d0594a46036e058004070 /gnu/packages/scanner.scm
parent4febd4b0f4fc99eb9357180166764febc410812e (diff)
downloadguix-patches-4ed390a0e7fc468303c07d6efebc54c80b2369c5.tar
guix-patches-4ed390a0e7fc468303c07d6efebc54c80b2369c5.tar.gz
gnu: sane-backends-minimal: Run most tests.
* gnu/packages/scanner.scm (sane-backends-minimal)[arguments]: Add a ‘disable-failing-tests’ phase to do just that, and run the rest.
Diffstat (limited to 'gnu/packages/scanner.scm')
-rw-r--r--gnu/packages/scanner.scm45
1 files changed, 24 insertions, 21 deletions
diff --git a/gnu/packages/scanner.scm b/gnu/packages/scanner.scm
index ff3e37f46c..f44f037efb 100644
--- a/gnu/packages/scanner.scm
+++ b/gnu/packages/scanner.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,32 +54,34 @@
(inputs
`(("libusb-compat" ,libusb-compat)))
(arguments
- `(#:tests? #f
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-before 'configure 'disable-backends
(lambda _
(setenv "BACKENDS" " ")
#t))
- (add-after
- 'install 'install-udev-rules
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (mkdir-p (string-append out "/lib/udev/rules.d"))
- (copy-file "tools/udev/libsane.rules"
- (string-append out
- "/lib/udev/rules.d/"
- "60-libsane.rules"))))))))
- ;; It would seem that tests are not maintained - fails with
- ;; the following:
- ;;
- ;; < This page was last updated on Wed Jul 31 07:52:48 2013
- ;; < by sane-desc 3.5 from sane-backends 1.0.24git
- ;; ---
- ;; > This page was last updated on Sun Oct 19 15:41:39 2014
- ;; > by sane-desc 3.5 from sane-backends 1.0.24
- ;; **** File generated for html-backends-split mode is different from reference
- ;; Makefile:501: recipe for target 'check.local' failed
+ ;; Disable unmaintained tests that that fail with errors resembling:
+ ;;
+ ;; < # by sane-desc 3.5 from sane-backends 1.0.24git on Jul 31 2013
+ ;; ---
+ ;; > # by sane-desc 3.5 from sane-backends 1.0.27 on 1970-01-01#
+ ;; FAIL: sane-desc -m usermap -s ./data
+ (add-before 'configure 'disable-failing-tests
+ (lambda _
+ (for-each
+ (lambda (pattern)
+ (substitute* "testsuite/tools/Makefile.in"
+ (((string-append " " pattern " ")) " ")))
+ (list "usermap" "db" "udev" "udev\\+acl" "udev\\+hwdb" "hwdb"))
+ #t))
+ (add-after 'install 'install-udev-rules
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/lib/udev/rules.d"))
+ (copy-file "tools/udev/libsane.rules"
+ (string-append out
+ "/lib/udev/rules.d/"
+ "60-libsane.rules"))))))))
(home-page "http://www.sane-project.org")
(synopsis
"Raster image scanner library and drivers, without scanner support")