summaryrefslogtreecommitdiff
path: root/gnu/packages/sawfish.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-02-01 22:26:09 +0800
committer宋文武 <iyzsong@gmail.com>2015-02-03 22:13:00 +0800
commita0aa8d0be0be0b1b93bef99b4ba8b85eda351b65 (patch)
treefb91708eba8d1a885dcfd20dad95e0b5f4917e88 /gnu/packages/sawfish.scm
parent93dc836f9dcdd2037711454ff5babb35e755bc27 (diff)
downloadguix-patches-a0aa8d0be0be0b1b93bef99b4ba8b85eda351b65.tar
guix-patches-a0aa8d0be0be0b1b93bef99b4ba8b85eda351b65.tar.gz
gnu: Add rep-gtk.
* gnu/packages/sawfish.scm (rep-gtk): New variable.
Diffstat (limited to 'gnu/packages/sawfish.scm')
-rw-r--r--gnu/packages/sawfish.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/sawfish.scm b/gnu/packages/sawfish.scm
index acf3e06883..4ba7b27e03 100644
--- a/gnu/packages/sawfish.scm
+++ b/gnu/packages/sawfish.scm
@@ -23,6 +23,7 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages gdbm)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages libffi)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages pkg-config)
@@ -64,3 +65,35 @@ subsequently diverged markedly. Its aim is to combine the best features of
Scheme and Common Lisp and provide an environment that is comfortable for
implementing both small and large scale systems.")
(license gpl2+)))
+
+(define-public rep-gtk
+ (package
+ (name "rep-gtk")
+ (version "0.90.8.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://download.tuxfamily.org/librep/"
+ name "/" name "_" version ".tar.xz"))
+ (sha256
+ (base32
+ "0qslm2isyv22hffdpw0nh7xk8jw8cj3h5y7d40c9h5r833w7j6sz"))
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* "Makefile.in"
+ (("installdir=\\$\\(repexecdir\\)")
+ ;; Install libraries for librep to $out/lib/rep.
+ "installdir=$(libdir)/rep")))))
+ (build-system gnu-build-system)
+ (arguments '(#:tests? #f)) ; no tests
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ ;; required by rep-gtk.pc.
+ `(("gtk+" ,gtk+-2)
+ ("librep" ,librep)))
+ (home-page "http://sawfish.wikia.com/wiki/Rep-GTK")
+ (synopsis "GTK+ binding for librep")
+ (description
+ "Rep-GTK is a GTK+ (and GLib, GDK) binding to the librep, and one of the
+backend of Sawfish.")
+ (license gpl2+)))