summaryrefslogtreecommitdiff
path: root/gnu/packages/sawfish.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/sawfish.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/sawfish.scm')
-rw-r--r--gnu/packages/sawfish.scm25
1 files changed, 9 insertions, 16 deletions
diff --git a/gnu/packages/sawfish.scm b/gnu/packages/sawfish.scm
index 4162fe43cd..1a09f8ca32 100644
--- a/gnu/packages/sawfish.scm
+++ b/gnu/packages/sawfish.scm
@@ -57,10 +57,7 @@
("automake" ,automake)
("libtool" ,libtool)))
(inputs
- `(("gdbm" ,gdbm)
- ("gmp" ,gmp)
- ("libffi" ,libffi)
- ("readline" ,readline)))
+ (list gdbm gmp libffi readline))
(native-search-paths
(list (search-path-specification
(variable "REP_DL_LOAD_PATH")
@@ -107,14 +104,10 @@ implementing both small and large scale systems.")
(delete-file "autogen.sh")
#t)))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ (list autoconf automake libtool pkg-config))
(propagated-inputs
;; required by rep-gtk.pc.
- `(("gtk+" ,gtk+-2)
- ("librep" ,librep)))
+ (list gtk+-2 librep))
(home-page "https://sawfish.fandom.com/wiki/Rep-GTK")
(synopsis "GTK+ binding for librep")
(description
@@ -180,12 +173,12 @@ backend of Sawfish.")
("pkg-config" ,pkg-config)
("which" ,which)))
(inputs
- `(("libsm" ,libsm)
- ("libxft" ,libxft)
- ("libxinerama" ,libxinerama)
- ("libxrandr" ,libxrandr)
- ("libxtst" ,libxtst)
- ("rep-gtk" ,rep-gtk)))
+ (list libsm
+ libxft
+ libxinerama
+ libxrandr
+ libxtst
+ rep-gtk))
(home-page "https://sawfish.tuxfamily.org")
(synopsis "Configurable window manager")
(description