summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 13:39:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:39:12 +0100
commitd83c52c6bb0401ae75245598328d480dd77c5a5e (patch)
tree1bb83c91af1c3526f430fadb18fa3b737e1bfb61 /gnu/packages/samba.scm
parented5900890ef8ed5635e8bc6aa9f8571926e7169d (diff)
downloadguix-patches-d83c52c6bb0401ae75245598328d480dd77c5a5e.tar
guix-patches-d83c52c6bb0401ae75245598328d480dd77c5a5e.tar.gz
gnu: talloc/static: Use INVOKE.
* gnu/packages/samba.scm (talloc/static)[arguments]: Use INVOKE in the build phase.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 213e416a4d..d3c0539c33 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -287,15 +287,9 @@ destructors. It is the core memory allocator used in Samba.")
`(modify-phases ,phases
(replace 'build
(lambda _
- (letrec-syntax ((shell (syntax-rules ()
- ((_ (command ...) rest ...)
- (and (zero? (system* command ...))
- (shell rest ...)))
- ((_)
- #t))))
- (shell ("gcc" "-c" "-Ibin/default" "-I" "lib/replace"
- "-I." "-Wall" "-g" "talloc.c")
- ("ar" "rc" "libtalloc.a" "talloc.o")))))
+ (invoke "gcc" "-c" "-Ibin/default" "-I" "lib/replace"
+ "-I." "-Wall" "-g" "talloc.c")
+ (invoke "ar" "rc" "libtalloc.a" "talloc.o")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))