summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2021-01-06 13:06:00 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-01-11 11:48:50 +0200
commitbd46b80aa1c82def8535ac3350dddeb98476360b (patch)
tree4b69a79937c21653040bcde546e30a86e48a7e48 /gnu/packages/samba.scm
parent458cb25b9e7e7c954f468023abea2bebb5d8c75b (diff)
downloadguix-patches-bd46b80aa1c82def8535ac3350dddeb98476360b.tar
guix-patches-bd46b80aa1c82def8535ac3350dddeb98476360b.tar.gz
gnu: ppp: Update to 2.4.9.
* gnu/packages/samba.scm (ppp): Update to 2.4.9. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm87
1 files changed, 42 insertions, 45 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 679e2ab869..13e03d7ac7 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -443,51 +443,48 @@ key-value pair databases and a real LDAP database.")
(license lgpl3+)))
(define-public ppp
- ;; This git commit contains unreleased fixes for CVE-2020-8597.
- (let ((revision "1")
- (commit "8d45443bb5c9372b4c6a362ba2f443d41c5636af"))
- (package
- (name "ppp")
- (version (git-version "2.4.8" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/paulusmack/ppp")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "06cf8fb84l3h2zy5da4j7k2j1qjv2gfqn986sf43xgj75605aks2"))))
- (build-system gnu-build-system)
- (arguments
- '(#:tests? #f ; no check target
- #:make-flags '("CC=gcc")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-Makefile
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((libc (assoc-ref inputs "libc"))
- (openssl (assoc-ref inputs "openssl"))
- (libpcap (assoc-ref inputs "libpcap")))
- (substitute* "pppd/Makefile.linux"
- (("/usr/include/crypt\\.h")
- (string-append libc "/include/crypt.h"))
- (("/usr/include/openssl")
- (string-append openssl "/include/openssl"))
- (("/usr/include/pcap-bpf.h")
- (string-append libpcap "/include/pcap-bpf.h")))
- #t))))))
- (inputs
- `(("libpcap" ,libpcap)
- ("openssl" ,(@ (gnu packages tls) openssl))))
- (synopsis "Implementation of the Point-to-Point Protocol")
- (home-page "https://ppp.samba.org/")
- (description
- "The Point-to-Point Protocol (PPP) provides a standard way to establish
+ (package
+ (name "ppp")
+ (version "2.4.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/paulusmack/ppp")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bhhksdclsnkw54a517ndrw55q5zljjbh9pcqz1z4a2z2flxpsgk"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no check target
+ #:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-Makefile
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libc (assoc-ref inputs "libc"))
+ (openssl (assoc-ref inputs "openssl"))
+ (libpcap (assoc-ref inputs "libpcap")))
+ (substitute* "pppd/Makefile.linux"
+ (("/usr/include/crypt\\.h")
+ (string-append libc "/include/crypt.h"))
+ (("/usr/include/openssl")
+ (string-append openssl "/include/openssl"))
+ (("/usr/include/pcap-bpf.h")
+ (string-append libpcap "/include/pcap-bpf.h")))
+ #t))))))
+ (inputs
+ `(("libpcap" ,libpcap)
+ ("openssl" ,(@ (gnu packages tls) openssl))))
+ (synopsis "Implementation of the Point-to-Point Protocol")
+ (home-page "https://ppp.samba.org/")
+ (description
+ "The Point-to-Point Protocol (PPP) provides a standard way to establish
a network connection over a serial link. At present, this package supports IP
and IPV6 and the protocols layered above them, such as TCP and UDP.")
- ;; pppd, pppstats and pppdump are under BSD-style notices.
- ;; some of the pppd plugins are GPL'd.
- ;; chat is public domain.
- (license (list bsd-3 bsd-4 gpl2+ public-domain)))))
+ ;; pppd, pppstats and pppdump are under BSD-style notices.
+ ;; some of the pppd plugins are GPL'd.
+ ;; chat is public domain.
+ (license (list bsd-3 bsd-4 gpl2+ public-domain))))