summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-15 07:30:13 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-15 14:58:33 +0100
commitadbfc6b9f1adefba488b44d8a0934bdb76d1e600 (patch)
treeb7392f6f410239238762946f70413f4c45034989 /gnu/packages/samba.scm
parenta9691718e894d0645014d0aeb79e3b867345b560 (diff)
downloadguix-patches-adbfc6b9f1adefba488b44d8a0934bdb76d1e600.tar
guix-patches-adbfc6b9f1adefba488b44d8a0934bdb76d1e600.tar.gz
gnu: talloc: Update to 2.1.11.
* gnu/packages/samba.scm (talloc): Update to 2.1.11. [arguments]: Run all tests. Use INVOKE.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm17
1 files changed, 6 insertions, 11 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 7cf02a62cb..4acd391a4a 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -233,31 +233,26 @@ Desktops into Active Directory environments using the winbind daemon.")
(define-public talloc
(package
(name "talloc")
- (version "2.1.10")
+ (version "2.1.11")
(source (origin
(method url-fetch)
(uri (string-append "https://www.samba.org/ftp/talloc/talloc-"
version ".tar.gz"))
(sha256
(base32
- "06gn45if56g81vbj3841fzdjsahrrczwqpfrydm2zv6nxd5yk1f9"))))
+ "1lzfxv2zjxap5snf9ydl1bqgjpz0kgkq7n644f8rkbx0arav77k3"))))
(build-system gnu-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
- ;; test_magic_differs.sh has syntax error, and is not in the right
- ;; place where wscript expected.
- ;; Skip the test.
- (substitute* "wscript"
- (("magic_ret = .*") "magic_ret = 0\n"))
- ;; talloc uses a custom configuration script that runs a
- ;; python script called 'waf'.
+ ;; talloc uses a custom configuration script that runs a Python
+ ;; script called 'waf', and doesn't tolerate unknown options.
(setenv "CONFIG_SHELL" (which "sh"))
(let ((out (assoc-ref outputs "out")))
- (zero? (system* "./configure"
- (string-append "--prefix=" out)))))))))
+ (invoke "./configure"
+ (string-append "--prefix=" out))))))))
(inputs
`(("python" ,python-2)))
(home-page "https://talloc.samba.org")