summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-08-27 18:40:55 +0200
committerMarius Bakke <marius@gnu.org>2022-08-27 23:48:56 +0200
commit9f8f34a16a57bd36aee8099b0052e4990140ba8d (patch)
tree1469c7f8cbf1f88b0e07c0830f67998d2a342cfe /gnu/packages/samba.scm
parent59bbf7e86c8b64850f7572d4af6a9587dfd3d7d0 (diff)
downloadguix-patches-9f8f34a16a57bd36aee8099b0052e4990140ba8d.tar
guix-patches-9f8f34a16a57bd36aee8099b0052e4990140ba8d.tar.gz
gnu: samba: Update to 4.16.4.
As a reproducibility check, you can check the hash: $ guix hash -r $(./pre-inst-env guix build samba --no-grafts --system=x86_64-linux) 1mg3nh705pbiz3ihq8jzkmjb15m6y8zjnzyr4hxmbciv7frgykk0 I've checked that it's correctly signed, and I've tried to verify that the PGP key is correct -- searching for 'Samba Distribution Verification Key', the websites of the first search results have the same key: * https://www.linuxcompatible.org/story/samba-4150rc5-released/ * https://wiki.samba.org/index.php/Samba_4.12_Features_added/changed * https://www.mail-archive.com/samba-announce@lists.samba.org/msg00562.html * https://wiki.linuxfromscratch.org/blfs/ticket/14748 https://groups.google.com/g/linux.samba/c/k3xaN0TIcQU has a different key, but as mentioned on the previous locations, the key has changed. I have also checked the source code diff (using diffoscope) between the the current version and the previous, nothing appears 'suspicious' (with the caveat that it is written in C). According to "guix refresh -l" there aren't too many dependents. I'm currently rebuilding them, no failures so far except for lxde, but it already failed to build before this patch. * gnu/packages/samba.scm (samba): Update to 4.16.4. To help future updaters, add the current PGP fingerprint in a comment. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index f6ead57cc1..360c06d216 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -185,14 +186,16 @@ external dependencies.")
(define-public samba
(package
(name "samba")
- (version "4.16.2")
+ (version "4.16.4")
(source
+ ;; For updaters: the current PGP fingerprint is
+ ;; 81F5E2832BD2545A1897B713AA99442FB680B620.
(origin
(method url-fetch)
(uri (string-append "https://download.samba.org/pub/samba/stable/"
"samba-" version ".tar.gz"))
(sha256
- (base32 "1745gx36gyd7353a94w4lrgksbmms0502kj9gg63il9zbdns1dx0"))))
+ (base32 "0bvhqinxwpbwp4ayhd9q8ga0w89gnkl1m3nrwpj1fnhjzd4ghclm"))))
(build-system gnu-build-system)
(arguments
(list