summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-02 15:07:10 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-02 22:21:15 +0100
commit966c56f8c6a458e1dce189c92f16d31aabe4ab66 (patch)
treedebf826aab08b969761f4fcf6d4a878baaf2352b /gnu/packages/samba.scm
parentc335df433fe890612521e51b2a12f313c5ba17c5 (diff)
downloadguix-patches-966c56f8c6a458e1dce189c92f16d31aabe4ab66.tar
guix-patches-966c56f8c6a458e1dce189c92f16d31aabe4ab66.tar.gz
gnu: talloc: Update to 2.1.16.
* gnu/packages/samba.scm (talloc): Update to 2.1.16. [native-inputs]: Add WHICH. [inputs]: Change from PYTHON-2 to PYTHON. (talloc/static)[arguments]: Adjust GCC command line.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 5ddc8748f3..346ec7c142 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -33,6 +33,7 @@
#:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages backup)
+ #:use-module (gnu packages base)
#:use-module (gnu packages check)
#:use-module (gnu packages crypto)
#:use-module (gnu packages cups)
@@ -240,14 +241,14 @@ Desktops into Active Directory environments using the winbind daemon.")
(define-public talloc
(package
(name "talloc")
- (version "2.1.14")
+ (version "2.1.16")
(source (origin
(method url-fetch)
(uri (string-append "https://www.samba.org/ftp/talloc/talloc-"
version ".tar.gz"))
(sha256
(base32
- "1kk76dyav41ip7ddbbf04yfydb4jvywzi2ps0z2vla56aqkn11di"))))
+ "1aajda08yf7njgvg6r21ccxlvkarb9bwvf4jqh8yn3871a1zcnqr"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -260,8 +261,10 @@ Desktops into Active Directory environments using the winbind daemon.")
(let ((out (assoc-ref outputs "out")))
(invoke "./configure"
(string-append "--prefix=" out))))))))
+ (native-inputs
+ `(("which" ,which)))
(inputs
- `(("python" ,python-2)))
+ `(("python" ,python)))
(home-page "https://talloc.samba.org")
(synopsis "Hierarchical, reference counted memory pool system")
(description
@@ -288,7 +291,8 @@ destructors. It is the core memory allocator used in Samba.")
(replace 'build
(lambda _
(invoke "gcc" "-c" "-Ibin/default" "-I" "lib/replace"
- "-I." "-Wall" "-g" "talloc.c")
+ "-I." "-Wall" "-g" "-D__STDC_WANT_LIB_EXT1__=1"
+ "talloc.c")
(invoke "ar" "rc" "libtalloc.a" "talloc.o")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)