summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-03 15:42:42 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-03 19:25:28 +0200
commit65a58f390704878e8adc8712786333ebd79c6a64 (patch)
tree85210ae3e25e3948eda16e1cf4ccb034584e5155 /gnu/packages/samba.scm
parent70dc8db8e7a44e0357c6b0582a710a918bd2e353 (diff)
downloadguix-patches-65a58f390704878e8adc8712786333ebd79c6a64.tar
guix-patches-65a58f390704878e8adc8712786333ebd79c6a64.tar.gz
gnu: ppp: Use OpenSSL for cryptography.
* gnu/packages/samba.scm (ppp)[source](patches): Add upstream patch. [inputs]: Add OPENSSL. [arguments]: Add substitution for OpenSSL headers.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index a6d6ee30cd..65d41a2b67 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -400,6 +400,18 @@ key-value pair databases and a real LDAP database.")
(method url-fetch)
(uri (string-append "https://www.samba.org/ftp/ppp/ppp-"
version ".tar.gz"))
+ (patches
+ (list (origin
+ ;; Use OpenSSL for cryptography instead of the obsolete glibc
+ ;; crypto functions that were removed in glibc 2.28.
+ (method url-fetch)
+ (uri (string-append "https://github.com/paulusmack/ppp/commit/"
+ "3c7b86229f7bd2600d74db14b1fe5b3896be3875"
+ ".patch"))
+ (file-name "ppp-use-openssl-crypto.patch")
+ (sha256
+ (base32
+ "0qlbi247lx3injpy8a1gcij9yilik0vfaibkpvdp88k3sa1rs69z")))))
(sha256
(base32
"0c7vrjxl52pdwi4ckrvfjr08b31lfpgwf3pp0cqy76a77vfs7q02"))))
@@ -412,15 +424,19 @@ key-value pair databases and a real LDAP database.")
(add-before 'configure 'patch-Makefile
(lambda* (#:key inputs #:allow-other-keys)
(let ((libc (assoc-ref inputs "libc"))
+ (openssl (assoc-ref inputs "openssl"))
(libpcap (assoc-ref inputs "libpcap")))
(substitute* "pppd/Makefile.linux"
(("/usr/include/crypt\\.h")
(string-append libc "/include/crypt.h"))
+ (("/usr/include/openssl")
+ (string-append openssl "/include/openssl"))
(("/usr/include/pcap-bpf.h")
(string-append libpcap "/include/pcap-bpf.h")))
#t))))))
(inputs
- `(("libpcap" ,libpcap)))
+ `(("libpcap" ,libpcap)
+ ("openssl" ,(@ (gnu packages tls) openssl))))
(synopsis "Implementation of the Point-to-Point Protocol")
(home-page "https://ppp.samba.org/")
(description