summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 18:29:53 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-27 12:46:31 +0200
commit55f0e9ccc54a47e708df9e7a21a21e5beb3b1745 (patch)
treedae7cd9fa523ee5e28490b0bee8c06012f47a1b4 /gnu/packages/samba.scm
parente8e3c3577ad37340583c8e83dff00d5cae4e3805 (diff)
downloadguix-patches-55f0e9ccc54a47e708df9e7a21a21e5beb3b1745.tar
guix-patches-55f0e9ccc54a47e708df9e7a21a21e5beb3b1745.tar.gz
gnu: cifs-utils: Return #t from all phases.
* gnu/packages/samba.scm (cifs-utils)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index e10f00a83b..98585905e9 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -76,7 +76,7 @@
;; The 6.7 tarball is missing ‘install.sh’. Create it.
(add-after 'unpack 'autoreconf
(lambda _
- (zero? (system* "autoreconf" "-i"))))
+ (invoke "autoreconf" "-i")))
(add-before 'configure 'set-root-sbin
(lambda _ ; Don't try to install in "/sbin".
(setenv "ROOTSBINDIR"