summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-04-12 03:45:00 -0400
committerMark H Weaver <mhw@netris.org>2018-04-12 04:02:56 -0400
commit444173f237f72cff3ed1f2d6783494e93f76d494 (patch)
treea4900c6890cb52eb98727673a3a61d707db392bf /gnu/packages/samba.scm
parent0371132c371b8736a91acb87e3c261dc9d956710 (diff)
downloadguix-patches-444173f237f72cff3ed1f2d6783494e93f76d494.tar
guix-patches-444173f237f72cff3ed1f2d6783494e93f76d494.tar.gz
gnu: iniparser: Return #t from all phases.
* gnu/packages/samba.scm (iniparser)[arguments]: Return #t from the custom configure and install phases.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index d84f52ffc5..dca2e166f5 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -112,7 +112,8 @@ the Linux kernel CIFS client.")
(lambda* (#:key outputs #:allow-other-keys)
(substitute* '("Makefile" "test/Makefile")
(("/usr/lib")
- (string-append (assoc-ref outputs "out") "/lib")))))
+ (string-append (assoc-ref outputs "out") "/lib")))
+ #t))
(replace 'build
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke "make" "libiniparser.so.1"
@@ -136,7 +137,8 @@ the Linux kernel CIFS client.")
(for-each (install html)
(find-files "html" ".*"))
(for-each (install doc)
- '("AUTHORS" "INSTALL" "LICENSE" "README.md"))))))))
+ '("AUTHORS" "INSTALL" "LICENSE" "README.md"))
+ #t))))))
(home-page "https://github.com/ndevilla/iniparser")
(synopsis "Standalone ini file parsing library")
(description