summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-01-01 22:22:08 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-01-02 18:54:26 +0100
commit43cb64d09bb5a92dc8e473c4b4243d0cc98f6883 (patch)
tree2bce28ec161a37b372565f1e2ecb56875d6ea0df /gnu/packages/samba.scm
parenta0ad182f4ca3c1ae9adfa7f6f1a82379724268b3 (diff)
downloadguix-patches-43cb64d09bb5a92dc8e473c4b4243d0cc98f6883.tar
guix-patches-43cb64d09bb5a92dc8e473c4b4243d0cc98f6883.tar.gz
gnu: cifs-utils: Update to 6.12.
* gnu/packages/samba.scm (cifs-utils): Update to 6.12. [arguments]: Remove obsolete 'bootstrap phase replacement.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index f869831dec..679e2ab869 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017, 2018, 2020 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
@@ -64,14 +64,14 @@
(define-public cifs-utils
(package
(name "cifs-utils")
- (version "6.11")
+ (version "6.12")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.samba.org/pub/linux-cifs/"
"cifs-utils/cifs-utils-" version ".tar.bz2"))
(sha256 (base32
- "1n98hy3zi4klm1xxhb840br1x7hhz0xx8kp5sch84kr07yd26ndq"))))
+ "1vw570pvir73kl4y6fhd6ns936ankimkhb1ii43yh8lr0p1xqbcj"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -87,12 +87,6 @@
(arguments
`(#:phases
(modify-phases %standard-phases
- (replace 'bootstrap
- ;; Force a bootstrap to fix a ‘cannot find install-sh, install.sh,
- ;; or shtool’ error since version 6.10.
- (lambda _
- (invoke "autoreconf" "-vfi")
- #t))
(add-before 'configure 'set-root-sbin
(lambda* (#:key outputs #:allow-other-keys)
;; Don't try to install into "/sbin".