summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 02:34:18 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 13:31:36 +0200
commit15e5d22fcbac028b8312d2cf3cd20844d9ee80e3 (patch)
treed2c9a4eabff249720be91ef9252d7e53225e7c1e /gnu/packages/samba.scm
parentac22683d64c6a7e10da4e4d93fb69ee921831511 (diff)
downloadguix-patches-15e5d22fcbac028b8312d2cf3cd20844d9ee80e3.tar
guix-patches-15e5d22fcbac028b8312d2cf3cd20844d9ee80e3.tar.gz
gnu: cifs-utils: Fix support for dropping capabilities.
* gnu/packages/samba.scm (cifs-utils)[arguments]: Add a new 'trigger-bootstrap phase.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 6f5f0db3c9..1a9e765c78 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -93,6 +93,11 @@
(list "--enable-man")
#:phases
(modify-phases %standard-phases
+ (add-before 'bootstrap 'trigger-bootstrap
+ ;; The shipped configure script is buggy, e.g., it contains a
+ ;; unexpanded literal ‘LIBCAP_NG_PATH’ line).
+ (lambda _
+ (delete-file "configure")))
(add-before 'configure 'set-root-sbin
(lambda* (#:key outputs #:allow-other-keys)
;; Don't try to install into "/sbin".