summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 02:25:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 13:31:35 +0200
commit0448bff770e470d2c627bd7cdd77ffb7c56ec202 (patch)
treee05a39255c0a27db7587b668f3db571d498b37ac /gnu/packages/samba.scm
parentec7bcdc35af17021a9dfd73ef49750d0ad82b989 (diff)
downloadguix-patches-0448bff770e470d2c627bd7cdd77ffb7c56ec202.tar
guix-patches-0448bff770e470d2c627bd7cdd77ffb7c56ec202.tar.gz
gnu: cifs-utils: Build & install man pages.
* gnu/packages/samba.scm (cifs-utils)[arguments]: Add "--enable-man" to #:configure-flags. Remove useless 'create-man8dir phase. Add a new 'install-man-pages phase to do just that. [native-inputs]: Add python-docutils.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm25
1 files changed, 16 insertions, 9 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 359a345029..6be167f4d4 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -55,6 +55,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
@@ -76,7 +77,10 @@
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+
+ ;; To generate the manpages.
+ ("python-docutils" ,python-docutils))) ; rst2man
(inputs
`(("keytuils" ,keyutils)
("linux-pam" ,linux-pam)
@@ -85,20 +89,23 @@
("samba" ,samba)
("talloc" ,talloc)))
(arguments
- `(#:phases
+ `(#:configure-flags
+ (list "--enable-man")
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'set-root-sbin
(lambda* (#:key outputs #:allow-other-keys)
;; Don't try to install into "/sbin".
(setenv "ROOTSBINDIR"
- (string-append (assoc-ref outputs "out") "/sbin"))
- #t))
- (add-before 'install 'create-man8dir
+ (string-append (assoc-ref outputs "out") "/sbin"))))
+ (add-before 'install 'install-man-pages
;; Create a directory that isn't created since version 6.10.
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (mkdir-p (string-append out "/share/man/man8"))
- #t))))))
+ (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
+ (apply invoke "make" "install-man"
+ `(,@(if parallel-build?
+ `("-j" ,(number->string (parallel-job-count)))
+ '())
+ ,@make-flags)))))))
(synopsis "User-space utilities for Linux CIFS (Samba) mounts")
(description "@code{cifs-utils} is a set of user-space utilities for
mounting and managing @dfn{Common Internet File System} (CIFS) shares using