summaryrefslogtreecommitdiff
path: root/gnu/packages/sagemath.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-06-21 16:32:58 +0200
committerAndreas Enge <andreas@enge.fr>2019-06-21 16:35:27 +0200
commite6049c84dab3031fb64defae2c45a20b512d4644 (patch)
tree6fffc230c09f1c24b6669d7af919ae40123ea57d /gnu/packages/sagemath.scm
parentb556abe416a3e79b7f3b8cf491d8a3179c3d31c8 (diff)
downloadguix-patches-e6049c84dab3031fb64defae2c45a20b512d4644.tar
guix-patches-e6049c84dab3031fb64defae2c45a20b512d4644.tar.gz
gnu: zn-poly: Install all libraries.
* gnu/packages/sagemath.scm (zn-poly): Install the static and the dynamic library with its symlinks, and end a phase with #t.
Diffstat (limited to 'gnu/packages/sagemath.scm')
-rw-r--r--gnu/packages/sagemath.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 7517b55175..d264eb560f 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -309,8 +309,19 @@ on numerical types, while GiNaC depends on CLN for this purpose.")
(invoke "make" "libzn_poly.so")))
(add-after 'install 'install-so
(lambda* (#:key outputs #:allow-other-keys)
- (let ((lib (string-append (assoc-ref outputs "out") "/lib")))
- (install-file "libzn_poly.so" lib)))))))
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib"))
+ (soname (string-append "libzn_poly-" ,version ".so"))
+ (target (string-append lib "/" soname)))
+ (install-file "libzn_poly.a" lib)
+ (install-file soname lib)
+ (symlink target
+ (string-append lib "/libzn_poly.so"))
+ (symlink target
+ (string-append lib "/libzn_poly-"
+ ,(version-major+minor version)
+ ".so")))
+ #t)))))
(synopsis "Arithmetic for polynomials over Z/NZ")
(description "zn_poly implements the arithmetic of polynomials the
coefficients of which are modular integers.")