summaryrefslogtreecommitdiff
path: root/gnu/packages/sagemath.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-06-17 02:10:52 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-07-10 23:03:42 +0200
commitdb7f74d2eb4878c0a9ed8bb33853090752277370 (patch)
tree664729435aec1b2c42ab4fef2b51afe8519502af /gnu/packages/sagemath.scm
parent5b9822cf43f0e568fc42a0a60a7ed4d77e5e9832 (diff)
downloadguix-patches-db7f74d2eb4878c0a9ed8bb33853090752277370.tar
guix-patches-db7f74d2eb4878c0a9ed8bb33853090752277370.tar.gz
gnu: lcalc: Don't rename the include directory.
Sage no longer renames the directory, so we shouldn't either. * gnu/packages/sagemath.scm (lcalc)[arguments]: Remove a substitution from the prepare-build phase.
Diffstat (limited to 'gnu/packages/sagemath.scm')
-rw-r--r--gnu/packages/sagemath.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index c94020f13e..8c837fdaeb 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -368,10 +368,7 @@ used as internal storage type for polynomial structures.")
(let ((out (assoc-ref outputs "out")))
(substitute* "Makefile"
(("^INSTALL_DIR= /usr/local")
- (string-append "INSTALL_DIR=" out))
- ;; Sage renames the include directory, so we do it also.
- (("include/Lfunction")
- "include/libLfunction")))
+ (string-append "INSTALL_DIR=" out))))
#t))
(add-before 'install 'make-output-dirs
(lambda* (#:key outputs #:allow-other-keys)