summaryrefslogtreecommitdiff
path: root/gnu/packages/sagemath.scm
diff options
context:
space:
mode:
authorvicvbcun <guix@ikherbers.com>2022-08-08 17:45:40 +0200
committerAndreas Enge <andreas@enge.fr>2022-08-12 10:21:00 +0200
commitd5a641dc2e28c0c944d5c4769d8171f79a187541 (patch)
tree888b11fdfdae14f07e38e55eac64cfb1724b3f15 /gnu/packages/sagemath.scm
parent2e821717d34a24fec2422913f0c4fb975b86b0f4 (diff)
downloadguix-patches-d5a641dc2e28c0c944d5c4769d8171f79a187541.tar
guix-patches-d5a641dc2e28c0c944d5c4769d8171f79a187541.tar.gz
gnu: lcalc: Update to 2.0.5.
* gnu/packages/sagemath.scm (lcalc): Update to 2.0.5. * gnu/packages/patches/lcalc-default-parameters-1.patch, gnu/packages/patches/lcalc-default-parameters-2.patch, gnu/packages/patches/lcalc-lcommon-h.patch, gnu/packages/patches/lcalc-using-namespace-std.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Unregister files. Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/sagemath.scm')
-rw-r--r--gnu/packages/sagemath.scm72
1 files changed, 21 insertions, 51 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index bb80ff4db5..4542bc1c88 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -38,6 +38,7 @@
#:use-module (gnu packages lisp)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages popt)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz))
@@ -309,59 +310,28 @@ used as internal storage type for polynomial structures.")
(define-public lcalc
(package
(name "lcalc")
- (version "1.23")
- ;; The original home page of the project has disappeared, as well as
- ;; code hosted by the original author on Google Code. The latter has
- ;; been copied to gitlab.com/sagemath and purportedly contains patches
- ;; for a never released version 1.3, that supposedly follows 1.23.
- ;; We use the tarball as well as the patches hosted inside the sage
- ;; package system distributed with the sage tarball.
- (source
- (origin
- (method url-fetch)
- (uri (string-append "ftp://ftp.fu-berlin.de/unix/misc/sage/spkg/"
- "upstream/lcalc/lcalc-1.23.tar.bz2"))
- (sha256
- (base32
- "1c6dsdshgxhqppjxvxhp8yhpxaqvnz3d1mlh26r571gkq8z2bm43"))
- (patches (search-patches "lcalc-lcommon-h.patch"
- "lcalc-default-parameters-1.patch"
- "lcalc-default-parameters-2.patch"
- "lcalc-using-namespace-std.patch"))))
+ (version "2.0.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/sagemath/lcalc")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rwyx292y3jbsp88wagn9nhl9z7wsnl2yrs5imxkbxq87pnrj5a7"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ;no tests
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'prepare-build
- (lambda* (#:key outputs #:allow-other-keys)
- (chdir "src")
- (let ((out (assoc-ref outputs "out")))
- (substitute* "Makefile"
- (("^INSTALL_DIR= /usr/local")
- (string-append "INSTALL_DIR=" out))))
- #t))
- (add-before 'install 'make-output-dirs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (lib (string-append out "/lib"))
- (include (string-append out "/include")))
- (mkdir-p bin)
- (mkdir-p lib)
- (mkdir-p include))
- #t)))))
- ;; FIXME:
- ;; We need to add pari-gp and probably pari related patches from the
- ;; sage project, as well as uncomment the line setting PARI_DEFINE in
- ;; the Makefile to get the full functionality of this package.
- ;; For the time being, we hope that sage can be compiled without.
- (synopsis "C++ library for L-functions")
- (description "Lcalc computes L-functions, in particular the Riemann
-zeta function and its twists by quadratic characters.")
- (license license:gpl2+)
- (home-page "https://gitlab.com/sagemath/sage")))
+ (list #:configure-flags '(list "--with-pari")))
+ (inputs (list pari-gp))
+ (native-inputs (list autoconf automake libtool pkg-config gengetopt))
+ (home-page "https://gitlab.com/sagemath/lcalc")
+ (synopsis "C++ library for computing with L-functions")
+ (description
+ "Lcalc computes L-functions, in particular the Riemann zeta function,
+Dirichlet L-functions and L-functions attached to elliptic curves and
+modular forms.")
+ (license license:gpl2+)))
(define-public ratpoints
(package