summaryrefslogtreecommitdiff
path: root/gnu/packages/sagemath.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-02-17 17:55:42 +0100
committerAndreas Enge <andreas@enge.fr>2019-02-17 17:55:42 +0100
commit5e388a6ebb3c287e2d54e03a3f37560beb0d75e9 (patch)
tree04baaecedea3e58a6a20bbe82fd122f90e1d8d44 /gnu/packages/sagemath.scm
parent3f074a21f0bf339491d993d61e9512d84984896b (diff)
downloadguix-patches-5e388a6ebb3c287e2d54e03a3f37560beb0d75e9.tar
guix-patches-5e388a6ebb3c287e2d54e03a3f37560beb0d75e9.tar.gz
gnu: Add python-gmpy2 and python2-gmpy2.
* gnu/packages/sagemath.scm (python-gmpy2, python2-gmpy2): New variables.
Diffstat (limited to 'gnu/packages/sagemath.scm')
-rw-r--r--gnu/packages/sagemath.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index dd8c062d31..06c4c0a17d 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -22,6 +22,7 @@
#:use-module (guix download)
#:use-module (guix build-system python)
#:use-module (gnu packages algebra)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz))
@@ -58,3 +59,33 @@ but it can be used independently.")
(define-public python2-cypari2
(package-with-python2 python-cypari2))
+;; The stable version of the following package is not young enough to be
+;; used with Sage, since it does not support cython. One would need to
+;; use an alpha release. On the other hand, Sage can be built without it.
+(define-public python-gmpy2
+ (package
+ (name "python-gmpy2")
+ (version "2.0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gmpy2" version ".zip"))
+ (sha256
+ (base32
+ "0grx6zmi99iaslm07w6c2aqpnmbkgrxcqjrqpfq223xri0r3w8yx"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (inputs
+ `(("gmp" ,gmp)
+ ("mpfr" ,mpfr)
+ ("mpc" ,mpc)))
+ (home-page "https://github.com/aleaxit/gmpy")
+ (synopsis
+ "GMP/MPIR, MPFR, and MPC interface to Python 2.6+ and 3.x")
+ (description
+ "GMP/MPIR, MPFR, and MPC interface to Python 2.6+ and 3.x")
+ (license #f)))
+
+(define-public python2-gmpy2
+ (package-with-python2 python-gmpy2))