summaryrefslogtreecommitdiff
path: root/gnu/packages/sagemath.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-06-18 00:12:36 +0200
committerAndreas Enge <andreas@enge.fr>2019-06-18 00:14:14 +0200
commit4c32f116cd89d158960c93ada28c32f3738e7b16 (patch)
tree0a1ba0e6202da6b4807c768e4b45ea43d1afe8fb /gnu/packages/sagemath.scm
parent972ef8f591fcdbd5d5bb33d0f8dc6f6c40adf952 (diff)
downloadguix-patches-4c32f116cd89d158960c93ada28c32f3738e7b16.tar
guix-patches-4c32f116cd89d158960c93ada28c32f3738e7b16.tar.gz
gnu: Add libhomfly.
* gnu/packages/sagemath.scm (libhomfly): New variable.
Diffstat (limited to 'gnu/packages/sagemath.scm')
-rw-r--r--gnu/packages/sagemath.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 91b46a8890..9736f79dc3 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -25,6 +25,7 @@
#:use-module (guix packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages bdw-gc)
#:use-module (gnu packages compression)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages python)
@@ -144,3 +145,31 @@ function for every found clique.")
in particular it computes normal forms of group elements.")
(license license:gpl2+)
(home-page "https://github.com/miguelmarco/libbraiding")))
+
+(define-public libhomfly
+ (package
+ (name "libhomfly")
+ (version "1.02r6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/miguelmarco/"
+ name))
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0sv3cwrf9v9sb5a8wbhjmarxvya13ma3j8y8592f9ymxlk5y0ldk"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (inputs
+ `(("libgc" ,libgc)))
+ (synopsis "Computation of homfly polynomials of links")
+ (description "libhomfly computes homfly polynomials of links,
+represented as strings.")
+ (license license:public-domain)
+ (home-page "https://github.com/miguelmarco/libhomfly")))