summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorIvan Petkov <ivanppetkov@gmail.com>2019-05-02 03:38:13 -0700
committerDanny Milosavljevic <dannym@scratchpost.org>2019-05-10 00:44:08 +0200
commitbea01c0d2ba4d4198423a014ae0322e0817a803a (patch)
tree66099157ae87f09e4ced06d20bd3e20e92ef2552 /gnu/packages/rust.scm
parente88735b45fcfb0c40c6ba4d4076411b7241547f3 (diff)
downloadguix-patches-bea01c0d2ba4d4198423a014ae0322e0817a803a.tar
guix-patches-bea01c0d2ba4d4198423a014ae0322e0817a803a.tar.gz
gnu: rust: Delete install logs and manifests.
* gnu/packages/rust.scm (rust-1.20)[arguments]<#:phases>[delete-install-logs]: New phase. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 27388d307e..becb804f18 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -597,6 +597,24 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
(("prefix = \"[^\"]*\"")
(string-append "prefix = \"" (assoc-ref outputs "cargo") "\"")))
(invoke "./x.py" "install" "cargo")))
+ (add-after 'install 'delete-install-logs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (define (delete-manifest-file out-path file)
+ (delete-file (string-append out-path "/lib/rustlib/" file)))
+
+ (let ((out (assoc-ref outputs "out"))
+ (cargo-out (assoc-ref outputs "cargo")))
+ (for-each
+ (lambda (file) (delete-manifest-file out file))
+ '("install.log"
+ "manifest-rust-docs"
+ "manifest-rust-std-x86_64-unknown-linux-gnu"
+ "manifest-rustc"))
+ (for-each
+ (lambda (file) (delete-manifest-file cargo-out file))
+ '("install.log"
+ "manifest-cargo"))
+ #t)))
(add-after 'install 'wrap-rustc
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))