summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-28 10:55:03 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-29 19:50:53 +0300
commit810f4cc187fff8dfae0ddde460f48b383498d482 (patch)
tree57755a05917298521b05ee49c310d71511c12c8d /gnu/packages/rust.scm
parentbbee4490d961ceb8d025726b04ea0f2a40355186 (diff)
downloadguix-patches-810f4cc187fff8dfae0ddde460f48b383498d482.tar
guix-patches-810f4cc187fff8dfae0ddde460f48b383498d482.tar.gz
gnu: rust-1.28: Remove disable-cargo-test-for-nightly-channel phase.
* gnu/packages/rust.scm (rust-1.28)[arguments]: Remove custom 'disable-cargo-test-for-nightly-channel phase. (rust-1.40)[arguments]: Don't remove removed phase.
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index a123bc4eec..0c15205773 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -800,7 +800,6 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
(("fn finds_author_git") "#[ignore]\nfn finds_author_git")
(("fn finds_local_author_git") "#[ignore]\nfn finds_local_author_git"))
#t))
- ;; TODO(rebuild-rust): Remove this phase in rust-1.28 when rebuilding.
(add-after 'patch-cargo-tests 'disable-cargo-test-for-nightly-channel
(lambda* _
;; This test failed to work on "nightly" channel builds
@@ -880,6 +879,8 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
(substitute* "src/test/run-pass/issue-44056.rs"
(("only-x86_64") "ignore-test"))
#t))
+ ;; This is no longer needed as of 1.28
+ (delete 'disable-cargo-test-for-nightly-channel)
;; The thinlto test should pass with llvm 6.
(delete 'disable-thinlto-test))))))))
@@ -1249,8 +1250,6 @@ move around."
,(patch-command-exec-tests-phase
'(match (find-files "src/test" "command-exec\\.rs")
((file) file))))
- ;; TODO(rebuild-rust): The test in question got fixed long ago.
- (delete 'disable-cargo-test-for-nightly-channel)
;; The test got removed in commit 000fe63b6fc57b09828930cacbab20c2ee6e6d15
;; "Remove painful test that is not pulling its weight"
(delete 'remove-unsupported-tests)))))))))