summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-03-17 10:59:56 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2019-03-17 11:04:36 +0100
commit7311ed3f869a6b18dd183acdd135d033b2f2cdb0 (patch)
tree87bb6c81228ddf7e104ca3461b37bf6c982ae089 /gnu/packages/rust.scm
parent707c761f1bf0b727650a1492bf02e99af00579f7 (diff)
downloadguix-patches-7311ed3f869a6b18dd183acdd135d033b2f2cdb0.tar
guix-patches-7311ed3f869a6b18dd183acdd135d033b2f2cdb0.tar.gz
gnu: rust: Work around Hydra bug.
* gnu/packages/rust.scm (rust-1.20)[properties]: Work around Hydra bug.
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index be916743fb..048a91052d 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -430,7 +430,13 @@ safety and thread safety guarantees.")
(package
(inherit base-rust)
(outputs '("out" "doc" "cargo"))
- (properties '())
+ ;; Since rust-1.19 is local, it's quite probable that Hydra
+ ;; will build rust-1.19 only as a dependency of rust-1.20.
+ ;; But then Hydra will use the wrong properties, the ones here,
+ ;; for rust-1.19. Therefore, we copied the properties of
+ ;; rust-1.19 here.
+ (properties '((timeout . 72000) ;20 hours
+ (max-silent-time . 18000))) ;5 hours (for armel)
(arguments
(substitute-keyword-arguments (package-arguments rust-1.19)
((#:phases phases)