summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-02 23:27:14 +0200
committerMarius Bakke <marius@gnu.org>2020-07-02 23:30:21 +0200
commit6ba3980e748099d9ee21abd246aeb86ed777744c (patch)
tree8503bc4f5c7838b04a121af2b0e9da08dc8bf214 /gnu/packages/rust.scm
parent5e6d583954b8ca9c4ab2eed3347a92a3ad7ad6fb (diff)
downloadguix-patches-6ba3980e748099d9ee21abd246aeb86ed777744c.tar
guix-patches-6ba3980e748099d9ee21abd246aeb86ed777744c.tar.gz
gnu: Rust: Use gdb@8.
* gnu/packages/rust.scm (rust-1.19)[native-inputs]: Remove GDB-MINIMAL. Add GDB-8.2. (rust-1.27)[native-inputs]: Remove.
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index b084a6df9e..9e753d6f99 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -420,7 +420,9 @@ test = { path = \"../libtest\" }
`(("bison" ,bison) ; For the tests
("cmake" ,cmake-minimal)
("flex" ,flex) ; For the tests
- ("gdb" ,gdb-minimal) ; For the tests
+ ;; FIXME: Rust 1.27 and some later versions require GDB 8.2 specifically.
+ ;; See <https://bugs.gnu.org/37810>. Use it on all Rusts for simplicity.
+ ("gdb" ,gdb-8.2) ; For the tests
("procps" ,procps) ; For the tests
("python-2" ,python-2)
("rustc-bootstrap" ,mrustc)
@@ -825,11 +827,6 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
"rust-bootstrap-stage0-test.patch"
"rust-1.25-accept-more-detailed-gdb-lines.patch"
"rust-reproducible-builds.patch")))))
- (native-inputs
- ;; FIXME: Rust 1.27 and some later versions require GDB 8.2 specifically.
- ;; See <https://bugs.gnu.org/37810>.
- (alist-replace "gdb" (list gdb-8.2)
- (package-native-inputs base-rust)))
(arguments
(substitute-keyword-arguments (package-arguments base-rust)
((#:phases phases)