summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-30 15:07:49 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-03-30 15:07:49 +0200
commit47cd0febe957b698cc2ae28978bdc3bc89e787f9 (patch)
tree2a5085b31bf8f5f703c5da630169cfe39a44b427 /gnu/packages/rust.scm
parent1808e64de095c8b0960bc8ac8df0ef48a5f95109 (diff)
downloadguix-patches-47cd0febe957b698cc2ae28978bdc3bc89e787f9.tar
guix-patches-47cd0febe957b698cc2ae28978bdc3bc89e787f9.tar.gz
gnu: rust: Build with Make 4.2.
Fixes <https://bugs.gnu.org/39949>. * gnu/packages/rust.scm (rust-1.20)[native-inputs]: Add GNU-MAKE-4.2.
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 6774603db6..5e5748f199 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -469,6 +469,10 @@ safety and thread safety guarantees.")
(delete-file-recursively "src/llvm")
#t))
(patches '())))
+ (native-inputs
+ `(;; The tests fail with newer versions of GNU Make.
+ ("make" ,gnu-make-4.2)
+ ,@(package-native-inputs base-rust)))
(outputs '("out" "doc" "cargo"))
;; Since rust-1.19 is local, it's quite probable that Hydra
;; will build rust-1.19 only as a dependency of rust-1.20.