summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-18 02:28:59 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:35 -0500
commit006ee1692649bb4cc6304d69152687022439df3a (patch)
tree291862d799602eb487ac736caf8d817bddeaba2c /gnu/packages/rust.scm
parentacaec1b5b72697b352f85ee0ed8dde623d055114 (diff)
downloadguix-patches-006ee1692649bb4cc6304d69152687022439df3a.tar
guix-patches-006ee1692649bb4cc6304d69152687022439df3a.tar.gz
gnu: rust-1.39: Update mrustc to commit c70665.
This brings us closer to a i686 native bootstrap. * gnu/packages/rust.scm (%mrustc-commit): Update to latest commit, c70665.
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index f8a7222005..572f7e0c72 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -122,7 +122,7 @@
;;; to be used in source form. The latest support for bootstrapping from
;;; 1.39.0 is not yet released so use the latest commit (see:
;;; https://github.com/thepowersgang/mrustc/issues/185).
-(define %mrustc-commit "474bec9cfd7862a20e7288cecd7fcf5e18648b9a")
+(define %mrustc-commit "c7066542f8e93d320323749216bf3c82aecb67c2")
(define %mrustc-source
(let* ((version "0.9")
(commit %mrustc-commit)
@@ -136,7 +136,7 @@
(file-name (git-file-name name (git-version version revision commit)))
(sha256
(base32
- "1zacz5qia0r457mv74wvrvznnv4az5g2w9j8ji9ssy727wljhvz7")))))
+ "0zv1x6601s5fnnkcdlqkc4bknisqz569qb0iyb9rjsmaf1kh0na3")))))
;;; Rust 1.39 is special in that it is built with mrustc, which shortens the
;;; bootstrap path.