summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-cbindgen.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-23 09:39:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-23 10:30:55 +0300
commite99fbcad344367d8b6acee13f1f6dfbbcb8a1377 (patch)
tree4b508e1fd54841d81198331f6f0aaf9ca3abe288 /gnu/packages/rust-cbindgen.scm
parentf3fd5f4bca2d81e2b8a031e4c2744f9da18ca5fb (diff)
downloadguix-patches-e99fbcad344367d8b6acee13f1f6dfbbcb8a1377.tar
guix-patches-e99fbcad344367d8b6acee13f1f6dfbbcb8a1377.tar.gz
gnu: Add rust-ansi-term-0.11.
* gnu/packages/rust-cbindgen.scm (rust-ansi-term-0.11): New file, new hidden variable. * gnu/local.mk (GNU_SYSTEM_MODULES): Register it.
Diffstat (limited to 'gnu/packages/rust-cbindgen.scm')
-rw-r--r--gnu/packages/rust-cbindgen.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/rust-cbindgen.scm b/gnu/packages/rust-cbindgen.scm
new file mode 100644
index 0000000000..aab4a81f5c
--- /dev/null
+++ b/gnu/packages/rust-cbindgen.scm
@@ -0,0 +1,44 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages rust-cbindgen)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system cargo))
+
+(define rust-ansi-term-0.11
+ (package
+ (name "rust-ansi-term")
+ (version "0.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ansi_term" version))
+ (file-name (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "16wpvrghvd0353584i1idnsgm0r3vchg8fyrm0x8ayv1rgvbljgf"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/ogham/rust-ansi-term")
+ (synopsis "Library for ANSI terminal colours and styles")
+ (description
+ "This is a library for controlling colours and formatting, such as red bold
+text or blue underlined text, on ANSI terminals.")
+ (properties '((hidden? . #t)))
+ (license license:expat)))