summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-02 15:59:52 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:17:05 +0200
commitc5c4876155350580fa205a7a560b662ece36b630 (patch)
tree6409ea21a2198ad0a8d9a40c3692bbab46b79cf7 /gnu/packages/rust-apps.scm
parentba33cf6d54deb2db01ce023d17071e43a86a61de (diff)
downloadguix-patches-c5c4876155350580fa205a7a560b662ece36b630.tar
guix-patches-c5c4876155350580fa205a7a560b662ece36b630.tar.gz
gnu: rust-cbindgen: Move to rust-apps.scm
* gnu/packages/rust-cbindgen.scm (rust-cbindgen): Move to ... * gnu/packages/rust-apps.scm: ... here. * gnu/local.mk (GNU_SYSTEM_MODULES): Remove it.
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm64
1 files changed, 64 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index e334e46daa..0f3650f52f 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -61,3 +62,66 @@
your current directory for a regex pattern while respecting your
gitignore rules.")
(license (list license:unlicense license:expat))))
+
+(define-public rust-cbindgen
+ (package
+ (name "rust-cbindgen")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cbindgen" version))
+ (file-name (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "1zgamxahlxmg4warzivaa8m1f8d6b45mhznm7n6d7p5l18acdblx"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("clap" ,rust-clap-2)
+ ("log" ,rust-log-0.4)
+ ("proc-macro2" ,rust-proc-macro2-1.0)
+ ("quote" ,rust-quote-1.0)
+ ("serde" ,rust-serde-1.0)
+ ("serde-json" ,rust-serde-json-1.0)
+ ("syn" ,rust-syn-1.0)
+ ("tempfile" ,rust-tempfile-3.0)
+ ("toml" ,rust-toml-0.5))
+ #:cargo-development-inputs
+ (("ansi-term" ,rust-ansi-term-0.11)
+ ("atty" ,rust-atty-0.2)
+ ("autocfg" ,rust-autocfg-0.1)
+ ("bitflags" ,rust-bitflags-1)
+ ("cfg-if" ,rust-cfg-if-0.1)
+ ("cloudabi" ,rust-cloudabi-0.0)
+ ("fuchsia-cprng" ,rust-fuchsia-cprng-0.1)
+ ("itoa" ,rust-itoa-0.4)
+ ("libc" ,rust-libc-0.2)
+ ("numtoa" ,rust-numtoa-0.1)
+ ("rand" ,rust-rand-0.6)
+ ("rand-chacha" ,rust-rand-chacha-0.1)
+ ("rand-core" ,rust-rand-core-0.3)
+ ("rand-hc" ,rust-rand-hc-0.1)
+ ("rand-isaac" ,rust-rand-isaac-0.1)
+ ("rand-jitter" ,rust-rand-jitter-0.1)
+ ("rand-os" ,rust-rand-os-0.1)
+ ("rand-pcg" ,rust-rand-pcg-0.1)
+ ("rand-xorshift" ,rust-rand-xorshift-0.1)
+ ("rdrand" ,rust-rdrand-0.4)
+ ("redox-syscall" ,rust-redox-syscall-0.1)
+ ("redox-termios" ,rust-redox-termios-0.1)
+ ("remove-dir-all" ,rust-remove-dir-all-0.5)
+ ("ryu" ,rust-ryu-1.0)
+ ("serde-derive" ,rust-serde-derive-1.0)
+ ("strsim" ,rust-strsim-0.8)
+ ("termion" ,rust-termion-1.5)
+ ("textwrap" ,rust-textwrap-0.11)
+ ("unicode-width" ,rust-unicode-width-0.1)
+ ("unicode-xid" ,rust-unicode-xid-0.2)
+ ("vec-map" ,rust-vec-map-0.8)
+ ("winapi" ,rust-winapi-0.3))))
+ (home-page "https://github.com/eqrion/cbindgen/")
+ (synopsis "Tool for generating C bindings to Rust code")
+ (description
+ "This package provides a tool for generating C/C++ bindings to Rust code.")
+ (license license:mpl2.0)))