summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2022-01-19 15:59:23 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 01:10:53 +0100
commitb68c1814f2601833e98847074e6f714af48aacd6 (patch)
tree14bfb9e051c7d6b9e07b85cfcb15b4e5abafb1ee /gnu/packages/rust-apps.scm
parent71f5af0c72d4cab5b7cf1c438ae0be43044e3f49 (diff)
downloadguix-patches-b68c1814f2601833e98847074e6f714af48aacd6.tar
guix-patches-b68c1814f2601833e98847074e6f714af48aacd6.tar.gz
gnu: rust-zeroize-1: Update to 1.5.0.
* gnu/packages/crates-io.scm (rust-zeroize-1): Update to 1.5.0. (rust-zeroize-derive-1): Update to 1.3.1. (rust-rsa-0.5): Enable build, and make sure it builds with rust-zeroize 1.5.0 by relaxing the dependency specification. * gnu/packages/rust-apps.scm (rbw): Relax the dependency specification for rust-zeroize. Also reword the description. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index d2cc949667..a97fcc7968 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1307,7 +1307,13 @@ runs a command whenever it detects modifications.")
(lambda _
(substitute*
"guix-vendor/rust-password-hash-0.3.2.tar.gz/Cargo.toml"
- (("version = \">=1, <1.1.0\"") "version = \">=1\"")))))
+ (("version = \">=1, <1.1.0\"") "version = \">=1\""))
+ (substitute*
+ "guix-vendor/rust-rsa-0.5.0.tar.gz/Cargo.toml"
+ (("version = \">=1, <1.5\"") "version = \"^1\""))
+ (substitute*
+ "Cargo.toml"
+ (("version = \"1.4\"") "version = \"^1\"")))))
#:cargo-inputs
(("rust-aes" ,rust-aes-0.7)
("rust-anyhow" ,rust-anyhow-1)
@@ -1352,9 +1358,9 @@ runs a command whenever it detects modifications.")
(home-page "https://git.tozt.net/rbw")
(synopsis "Unofficial Bitwarden CLI")
(description "This package is an unofficial command line client for
-Bitwarden. Although it does come with its own command line client, this client
-is limited by being stateless, which makes it very difficult to use. This
-client avoids this problem by maintaining a background process which is able
+Bitwarden. Although Bitwarden ships with a command line client, but
+it's limited by being stateless, which makes it very difficult to use. This
+client avoids that problem by maintaining a background process which is able
to hold the keys in memory, similar to the way that ssh-agent or gpg-agent
work. This allows the client to be used in a much simpler way, with the
background agent taking care of maintaining the necessary state.")