summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-12-05 04:53:12 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-05 19:46:10 +0100
commita3dea002c1734cf775c8beb1508f6d2ec0396e52 (patch)
tree9cb011fd42cfaa4f35d96266dfe0ba351f2b4055 /gnu/packages/rust-apps.scm
parent13f2f2d14d9597e5c49f84f5f903dea75c5177aa (diff)
downloadguix-patches-a3dea002c1734cf775c8beb1508f6d2ec0396e52.tar
guix-patches-a3dea002c1734cf775c8beb1508f6d2ec0396e52.tar.gz
gnu: Add hex.
* gnu/packages/rust-apps.scm (hex): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index be60f3f376..51075b5448 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -856,6 +856,36 @@ classic Web2C implementation of TeX and uses the TeXLive distribution
of support files.")
(license license:expat)))
+(define-public hex
+ (package
+ (name "hex")
+ (version "0.4.2")
+ (source
+ (origin
+ ;; crates.io does not provide the test data.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sitkevij/hex")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03x27nixdlnkkrh85gy4152arp02kpjwq0i9dn9p73lyr24s64lv"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-ansi-term" ,rust-ansi-term-0.12)
+ ("rust-atty" ,rust-atty-0.2)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-no-color" ,rust-no-color-0.1))
+ #:cargo-development-inputs
+ (("rust-assert-cmd" ,rust-assert-cmd-1))))
+ (home-page "https://github.com/sitkevij/hex")
+ (synopsis "Hexadecimal colorized view of a file")
+ (description
+ "@command{hx} accepts a file path as input and outputs a hexadecimal
+colorized view to stdout.")
+ (license license:expat)))
+
(define-public tokei
(package
(name "tokei")