summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/rust-apps.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm86
1 files changed, 81 insertions, 5 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 3225703e26..94667c79d5 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -703,14 +703,14 @@ of the project is to be runnable on untrusted networks without crashing.")
(define-public tectonic
(package
(name "tectonic")
- (version "0.7.1")
+ (version "0.8.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "tectonic" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0rjkfmbam81anpdqs2qafcmd5bf7y898c8a7iqqqwkbl1hfw4sqs"))))
+ (base32 "0hzyqpjxya6g1ifb3hvjvj0zl2aigx898pz7h5pl46z50jp2pdc8"))))
(build-system cargo-build-system)
(arguments
`(#:rust ,rust-1.52
@@ -730,14 +730,14 @@ of the project is to be runnable on untrusted networks without crashing.")
("rust-serde" ,rust-serde-1)
("rust-sha2" ,rust-sha2-0.9)
("rust-structopt" ,rust-structopt-0.3)
- ("rust-tectonic-bridge-core" ,rust-tectonic-bridge-core-0.2)
- ("rust-tectonic-bundles" ,rust-tectonic-bundles-0.1)
+ ("rust-tectonic-bridge-core" ,rust-tectonic-bridge-core-0.3)
+ ("rust-tectonic-bundles" ,rust-tectonic-bundles-0.2)
("rust-tectonic-docmodel" ,rust-tectonic-docmodel-0.1)
("rust-tectonic-engine-bibtex" ,rust-tectonic-engine-bibtex-0.1)
("rust-tectonic-engine-xdvipdfmx" ,rust-tectonic-engine-xdvipdfmx-0.1)
("rust-tectonic-engine-xetex" ,rust-tectonic-engine-xetex-0.1)
("rust-tectonic-errors" ,rust-tectonic-errors-0.2)
- ("rust-tectonic-geturl" ,rust-tectonic-geturl-0.2)
+ ("rust-tectonic-geturl" ,rust-tectonic-geturl-0.3)
("rust-tectonic-io-base" ,rust-tectonic-io-base-0.3)
("rust-tectonic-status-base" ,rust-tectonic-status-base-0.2)
("rust-tectonic-xdv" ,rust-tectonic-xdv-0.1)
@@ -1050,6 +1050,82 @@ library and a dynamic library, and a C header to be used by any C (and
C-compatible) software.")
(license license:expat)))
+(define-public tealdeer
+ (package
+ (name "tealdeer")
+ (version "1.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "tealdeer" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0cwf46k2rszcpydrqajnm4dvhggr3ms7sjma0jx02ch4fjicxch7"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-completions
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bash (string-append out "/etc/bash_completion.d/"))
+ (fish (string-append out "/share/fish/vendor_completions.d/")))
+ (mkdir-p bash)
+ (mkdir-p fish)
+ (copy-file "bash_tealdeer"
+ (string-append bash "tealdeer"))
+ (copy-file "fish_tealdeer"
+ (string-append fish "tealdeer.fish"))))))
+ #:install-source? #f
+ #:cargo-test-flags
+ '("--release" "--"
+ ;; These tests go to the network
+ "--skip=test_quiet_old_cache"
+ "--skip=test_quiet_cache"
+ "--skip=test_quiet_failures"
+ "--skip=test_pager_flag_enable"
+ "--skip=test_markdown_rendering"
+ "--skip=test_spaces_find_command"
+ "--skip=test_autoupdate_cache"
+ "--skip=test_update_cache")
+ #:cargo-inputs
+ (("rust-ansi-term" ,rust-ansi-term-0.12)
+ ("rust-app-dirs2" ,rust-app-dirs2-2)
+ ("rust-atty" ,rust-atty-0.2)
+ ("rust-docopt" ,rust-docopt-1)
+ ("rust-env-logger" ,rust-env-logger-0.7)
+ ("rust-flate2" ,rust-flate2-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-pager" ,rust-pager-0.15)
+ ("rust-reqwest" ,rust-reqwest-0.10)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-tar" ,rust-tar-0.4)
+ ("rust-toml" ,rust-toml-0.5)
+ ("rust-walkdir" ,rust-walkdir-2)
+ ("rust-xdg" ,rust-xdg-2))
+ #:cargo-development-inputs
+ (("rust-assert-cmd" ,rust-assert-cmd-1)
+ ("rust-escargot" ,rust-escargot-0.5)
+ ("rust-filetime" ,rust-filetime-0.2)
+ ("rust-predicates" ,rust-predicates-1)
+ ;; This earlier version is required to fix a bug.
+ ;; Remove rust-remove-dir-all-0.5.2 when tealdeer gets upgraded
+ ("rust-remove-dir-all" ,rust-remove-dir-all-0.5.2)
+ ("rust-tempfile" ,rust-tempfile-3))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("openssl" ,openssl)))
+ (home-page "https://github.com/dbrgn/tealdeer/")
+ (synopsis "Fetch and show tldr help pages for many CLI commands")
+ (description
+ "This package fetches and shows tldr help pages for many CLI commands.
+Full featured offline client with caching support.")
+ (license (list license:expat license:asl2.0))))
+
(define-public zoxide
(package
(name "zoxide")