summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-15 11:27:39 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:17:02 +0200
commit9e225670771bc08345ad5e7c686348024fa43acd (patch)
tree05b1e4e54fcef370d97f84f541704c24d1e00bb3 /gnu/packages/rust-apps.scm
parent04a89218a471346eef9503bd0eb8b142850833d6 (diff)
downloadguix-patches-9e225670771bc08345ad5e7c686348024fa43acd.tar
guix-patches-9e225670771bc08345ad5e7c686348024fa43acd.tar.gz
gnu: Add ripgrep.
* gnu/packages/rust-apps.scm (ripgrep): New variable. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
new file mode 100644
index 0000000000..e334e46daa
--- /dev/null
+++ b/gnu/packages/rust-apps.scm
@@ -0,0 +1,63 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages rust-apps)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system cargo)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module (gnu packages crates-io))
+
+(define-public ripgrep
+ (package
+ (name "ripgrep")
+ (version "11.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ripgrep" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0bn40lz9n08llq615p4qqqbi24zbkf0appfx3zgxg34a86ga9zds"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-bstr" ,rust-bstr-0.1)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-grep" ,rust-grep-0.2)
+ ("rust-ignore" ,rust-ignore-0.4)
+ ("rust-lazy-static" ,rust-lazy-static-1.3)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-num-cpus" ,rust-num-cpus-1.10)
+ ("rust-regex" ,rust-regex-1.1)
+ ("rust-serde-json" ,rust-serde-json-1.0)
+ ("rust-termcolor" ,rust-termcolor-1.0))
+ #:cargo-development-inputs
+ (("rust-clap" ,rust-clap-2)
+ ("rust-lazy-static" ,rust-lazy-static-1.3)
+ ("rust-serde" ,rust-serde-1.0)
+ ("rust-serde-derive" ,rust-serde-derive-1.0))))
+ (home-page "https://github.com/BurntSushi/ripgrep")
+ (synopsis "Line-oriented search tool")
+ (description
+ "ripgrep is a line-oriented search tool that recursively searches
+your current directory for a regex pattern while respecting your
+gitignore rules.")
+ (license (list license:unlicense license:expat))))