summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/rust-apps.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm52
1 files changed, 21 insertions, 31 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 5ad8fbd2cc..6d4f77adf8 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -145,10 +145,9 @@ low-end hardware and serving many concurrent requests.")
("rust-tempfile" ,rust-tempfile-3)
("rust-wait-timeout" ,rust-wait-timeout-0.2))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("libgit2" ,libgit2)
- ("zlib" ,zlib)))
+ (list libgit2 zlib))
(home-page "https://github.com/sharkdp/bat")
(synopsis "@command{cat} clone with syntax highlighting and git integration")
(description
@@ -228,9 +227,9 @@ highlighting tool to ease code review from your terminal.")
("rust-url" ,rust-url-2)
("rust-yaml-rust" ,rust-yaml-rust-0.4))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("openssl" ,openssl)))
+ (list openssl))
(home-page "https://github.com/fcsonline/drill")
(synopsis "HTTP load testing application")
(description
@@ -356,10 +355,9 @@ Features include:
(string-append share "/zsh/site-functions/_exa"))
#t))))))
(inputs
- `(("libgit2" ,libgit2)
- ("zlib" ,zlib)))
+ (list libgit2 zlib))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(home-page "https://the.exa.website/")
(synopsis "Modern replacement for ls")
(description "@code{exa} is a modern replacement for the command-line
@@ -431,7 +429,7 @@ also knows about symlinks, extended attributes, and Git.")
(rename-file (string-append out "/etc/bash_completion.d/fd.bash")
(string-append out "/etc/bash_completion.d/fd"))
#t))))))
- (inputs `(("jemalloc" ,jemalloc)))
+ (inputs (list jemalloc))
(home-page "https://github.com/sharkdp/fd")
(synopsis "Simple, fast and user-friendly alternative to find")
(description
@@ -597,7 +595,7 @@ characters, ASCII whitespace characters, other ASCII characters and non-ASCII.")
(wrap-program (string-append out "/bin/i3status-rs")
`("PATH" prefix ,paths))))))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
`(("alsa-utils" ,alsa-utils)
("bash-minimal" ,bash-minimal)
@@ -671,9 +669,7 @@ bar. It is also compatible with sway.")
#t)))
#:features '("pcre2")))
(native-inputs
- `(("asciidoc" ,asciidoc)
- ("pcre2" ,pcre2)
- ("pkg-config" ,pkg-config)))
+ (list asciidoc pcre2 pkg-config))
(home-page "https://github.com/BurntSushi/ripgrep")
(synopsis "Line-oriented search tool")
(description
@@ -742,7 +738,7 @@ gitignore rules.")
#:cargo-development-inputs
(("rust-serial-test" ,rust-serial-test-0.5))))
(native-inputs
- `(("python-cython" ,python-cython)))))
+ (list python-cython))))
(define-public rust-cbindgen-0.16
(package
@@ -874,8 +870,7 @@ gitignore rules.")
#:cargo-development-inputs
(("rust-boxxy" ,rust-boxxy-0.11))))
(inputs
- `(("libpcap" ,libpcap)
- ("libseccomp" ,libseccomp)))
+ (list libpcap libseccomp))
(home-page "https://github.com/kpcyrd/sniffglue")
(synopsis "Secure multithreaded packet sniffer")
(description
@@ -912,8 +907,8 @@ of the project is to be runnable on untrusted networks without crashing.")
("rust-tokio" ,rust-tokio-0.2)
("rust-tui" ,rust-tui-0.16)
("rust-unicode-width" ,rust-unicode-width-0.1))))
- (native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("openssl" ,openssl)))
+ (native-inputs (list pkg-config))
+ (inputs (list openssl))
(home-page "https://github.com/Rigellute/spotify-tui")
(synopsis "Terminal user interface for Spotify")
(description "This package provides a terminal user interface for Spotify")
@@ -981,7 +976,7 @@ of the project is to be runnable on untrusted networks without crashing.")
(doc (string-append out "/share/doc/" ,name "-" ,version)))
(copy-recursively "docs/src" doc)))))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
`(("fontconfig" ,fontconfig)
("harfbuzz" ,harfbuzz)
@@ -1068,11 +1063,9 @@ colorized view to stdout.")
("rust-regex" ,rust-regex-1)
("rust-tempfile" ,rust-tempfile-3))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("libgit2" ,libgit2)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
+ (list libgit2 openssl zlib))
(home-page "https://tokei.rs")
(synopsis "Count code, quickly")
(description
@@ -1317,12 +1310,9 @@ support for Rust.")
("rust-serde-json" ,rust-serde-json-1)
("rust-regex" ,rust-regex-1))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("curl" ,curl)
- ("libssh2" ,libssh2)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
+ (list curl libssh2 openssl zlib))
(home-page "https://github.com/lu-zero/cargo-c")
(synopsis "Build and install C-compatible libraries")
(description
@@ -1397,9 +1387,9 @@ C-compatible) software.")
("rust-remove-dir-all" ,rust-remove-dir-all-0.5.2)
("rust-tempfile" ,rust-tempfile-3))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("openssl" ,openssl)))
+ (list openssl))
(home-page "https://github.com/dbrgn/tealdeer/")
(synopsis "Fetch and show tldr help pages for many CLI commands")
(description
@@ -1447,7 +1437,7 @@ Full featured offline client with caching support.")
(man (string-append out "/share/man/man1")))
(install-file "Documentation/git-absorb.1" man)))))))
(inputs
- `(("zlib" ,zlib)))
+ (list zlib))
(home-page "https://github.com/tummychow/git-absorb")
(synopsis "Git tool for making automatic fixup commits")
(description