summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-01 23:24:00 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-01 23:46:08 +0100
commit6693ff05696d71a9ca556760a1597b48a95c5298 (patch)
tree60ecba671d0eb7cea04c1b20cf35151b614a161d /gnu/packages/rust-apps.scm
parent3854558c76ac51787f0fdb4cac226b678a9ad621 (diff)
downloadguix-patches-6693ff05696d71a9ca556760a1597b48a95c5298.tar
guix-patches-6693ff05696d71a9ca556760a1597b48a95c5298.tar.gz
gnu: tectonic: Update to 0.8.1.
* gnu/packages/rust-apps.scm (tectonic): Update to 0.8.1. [inputs]: Add FREETYPE, GRAPHITE2, ICU4C, LIBPNG. * gnu/packages/crates-io.scm (rust-pinot-0.1)[origin]<patches>: Add patch necessary for Tectonic. (rust-tectonic-docmodel-0.1): Update to 0.1.2. (rust-tectonic-engine-spx2html-0.1): New variable. (rust-tectonic-engine-xetex-0.2): New variable. (rust-tectonic-engine-xetex-0.1): Remove variable. (rust-tectonic-io-base-0.4): New variable. (rust-tectonic-io-base-0.3): Inherit from above. (rust-tectonic-xdv-0.2): New variable. (rust-tectonic-xdv-0.1): Remove variable. * gnu/packages/patches/rust-pinot-0.1-implement-math-table.patch: New file. * gnu/local.mk (dist_patch_DATA): Register new file.
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm23
1 files changed, 15 insertions, 8 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index a73a1e18ef..74d6b9fc85 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -53,6 +53,8 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages ibus)
+ #:use-module (gnu packages icu4c)
+ #:use-module (gnu packages image)
#:use-module (gnu packages jemalloc)
#:use-module (gnu packages kde)
#:use-module (gnu packages linux)
@@ -1048,14 +1050,14 @@ of the project is to be runnable on untrusted networks without crashing.")
(define-public tectonic
(package
(name "tectonic")
- (version "0.8.0")
+ (version "0.8.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "tectonic" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0hzyqpjxya6g1ifb3hvjvj0zl2aigx898pz7h5pl46z50jp2pdc8"))))
+ (base32 "036cgbnw4mykhprfvfh97gcgrlkbjrgv58fwqy8l6s0vwam66sdh"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-build-flags '("--release" "--features" "external-harfbuzz")
@@ -1078,13 +1080,14 @@ of the project is to be runnable on untrusted networks without crashing.")
("rust-tectonic-bundles" ,rust-tectonic-bundles-0.2)
("rust-tectonic-docmodel" ,rust-tectonic-docmodel-0.1)
("rust-tectonic-engine-bibtex" ,rust-tectonic-engine-bibtex-0.1)
+ ("rust-tectonic-engine-spx2html" ,rust-tectonic-engine-spx2html-0.1)
("rust-tectonic-engine-xdvipdfmx" ,rust-tectonic-engine-xdvipdfmx-0.1)
- ("rust-tectonic-engine-xetex" ,rust-tectonic-engine-xetex-0.1)
+ ("rust-tectonic-engine-xetex" ,rust-tectonic-engine-xetex-0.2)
("rust-tectonic-errors" ,rust-tectonic-errors-0.2)
("rust-tectonic-geturl" ,rust-tectonic-geturl-0.3)
("rust-tectonic-io-base" ,rust-tectonic-io-base-0.3)
("rust-tectonic-status-base" ,rust-tectonic-status-base-0.2)
- ("rust-tectonic-xdv" ,rust-tectonic-xdv-0.1)
+ ("rust-tectonic-xdv" ,rust-tectonic-xdv-0.2)
("rust-tectonic-xetex-layout" ,rust-tectonic-xetex-layout-0.1)
("rust-tempfile" ,rust-tempfile-3)
("rust-termcolor" ,rust-termcolor-1)
@@ -1109,10 +1112,14 @@ of the project is to be runnable on untrusted networks without crashing.")
(native-inputs
(list pkg-config))
(inputs
- `(("fontconfig" ,fontconfig)
- ("harfbuzz" ,harfbuzz)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
+ (list fontconfig
+ freetype
+ graphite2
+ harfbuzz
+ icu4c
+ libpng
+ openssl
+ zlib))
(home-page "https://tectonic-typesetting.github.io/")
(synopsis "Complete, embeddable TeX/LaTeX engine")
(description