summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2022-01-11 22:15:00 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-11 22:15:00 +0100
commit5053490ca5fed644f62f5506e4fff5af89db8f1f (patch)
tree04d124b09096d32fd335dbd999ada5c9e2e1246d /gnu/packages/rust-apps.scm
parent458deb70401ae75421ec219287c71e448fa11a49 (diff)
downloadguix-patches-5053490ca5fed644f62f5506e4fff5af89db8f1f.tar
guix-patches-5053490ca5fed644f62f5506e4fff5af89db8f1f.tar.gz
gnu: Add swayhide.
* gnu/packages/rust-apps.scm (swayhide): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 7dd60dd35b..7263fffe6a 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1328,6 +1329,31 @@ library and a dynamic library, and a C header to be used by any C (and
C-compatible) software.")
(license license:expat)))
+(define-public swayhide
+ (package
+ (name "swayhide")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "swayhide" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0x172ffj0lfmbv5nix708l1mfsizxzy74gpxp5amvx0bbaq0p78s"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-exitcode" ,rust-exitcode-1)
+ ("rust-swayipc" ,rust-swayipc-2))))
+ (home-page "https://github.com/NomisIV/swayhide/")
+ (synopsis "Swallow windows on swaywm")
+ (description "swayhide hides the currently active terminal (by moving it
+to the scratchpad), then it executes the supplied command. When the child
+process has finished, the terminal is moved back. This is useful if your
+workflow includes opening graphical programs from the terminal, as the locked
+terminal won't have to take up any space.")
+ (license license:gpl3+)))
+
(define-public tealdeer
(package
(name "tealdeer")