summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 11:49:15 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 11:49:15 +0100
commit1052ae5f03de931b52c7a638c8e4f8d8d7093af3 (patch)
tree4913e4a7834f4ad6e44906d814cd46e7c21d981b /gnu/packages/rust-apps.scm
parent869d69ad3248288ffe30264f5e5bd760792ca758 (diff)
parent788f56b4dc0729e07ad546c5bc9694759c271f09 (diff)
downloadguix-patches-1052ae5f03de931b52c7a638c8e4f8d8d7093af3.tar
guix-patches-1052ae5f03de931b52c7a638c8e4f8d8d7093af3.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm109
1 files changed, 87 insertions, 22 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 2b4b0e8eb0..5ad8fbd2cc 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -39,16 +39,22 @@
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages compression)
#:use-module (gnu packages crates-io)
#:use-module (gnu packages crates-graphics)
#:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages ibus)
#:use-module (gnu packages jemalloc)
+ #:use-module (gnu packages kde)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages networking)
#:use-module (gnu packages ssh)
#:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
@@ -56,7 +62,8 @@
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages rust)
#:use-module (gnu packages tls)
- #:use-module (gnu packages version-control))
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages xorg))
(define-public agate
(package
@@ -526,24 +533,16 @@ characters, ASCII whitespace characters, other ASCII characters and non-ASCII.")
(name "i3status-rust")
(version "0.20.1")
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/greshake/i3status-rust")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (patches (search-patches "i3status-rust-enable-unstable-features.patch"))
- (sha256
- (base32 "00gzm3g297s9bfp13vnb623p7dfac3g6cdhz2b3lc6l0kmnnqs1s"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/greshake/i3status-rust")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (patches (search-patches "i3status-rust-enable-unstable-features.patch"))
+ (sha256
+ (base32 "00gzm3g297s9bfp13vnb623p7dfac3g6cdhz2b3lc6l0kmnnqs1s"))))
(build-system cargo-build-system)
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("curl" ,curl)
- ("dbus" ,dbus)
- ("pulseaudio" ,pulseaudio)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
(arguments
`(#:features '("pulseaudio" "libpulse-binding")
#:install-source? #f
@@ -573,6 +572,9 @@ characters, ASCII whitespace characters, other ASCII characters and non-ASCII.")
(("rust-assert-fs" ,rust-assert-fs-1))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'enable-unstable-features
+ (lambda _
+ (setenv "RUSTC_BOOTSTRAP" "1")))
(add-after 'unpack 'fix-resources-path
(lambda* (#:key outputs #:allow-other-keys)
(let ((resources (string-append %output "/share")))
@@ -581,10 +583,38 @@ characters, ASCII whitespace characters, other ASCII characters and non-ASCII.")
(add-after 'install 'install-resources
(lambda* (#:key outputs #:allow-other-keys)
(copy-recursively "files" (string-append %output "/share"))))
- (add-after 'unpack 'enable-unstable-features
- (lambda _
- (setenv "RUSTC_BOOTSTRAP" "1")
- #t)))))
+ (add-after 'install 'wrap-i3status
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (paths (map
+ (lambda (input)
+ (string-append (assoc-ref inputs input) "/bin"))
+ '("alsa-utils" "coreutils" "curl" "dbus" "ibus" "iproute"
+ "kdeconnect" "lm-sensors" "pulseaudio"
+ "openssl"
+ "setxkbmap" "speedtest-cli" "xdg-utils" "xrandr"
+ "zlib"))))
+ (wrap-program (string-append out "/bin/i3status-rs")
+ `("PATH" prefix ,paths))))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("alsa-utils" ,alsa-utils)
+ ("bash-minimal" ,bash-minimal)
+ ("coreutils" ,coreutils)
+ ("curl" ,curl)
+ ("dbus" ,dbus)
+ ("ibus" ,ibus)
+ ("iproute" ,iproute)
+ ("kdeconnect" ,kdeconnect)
+ ("lm-sensors" ,lm-sensors)
+ ("pulseaudio" ,pulseaudio)
+ ("openssl" ,openssl)
+ ("setxkbmap" ,setxkbmap)
+ ("speedtest-cli" ,speedtest-cli)
+ ("xdg-utils" ,xdg-utils)
+ ("xrandr" ,xrandr)
+ ("zlib" ,zlib)))
(home-page "https://github.com/greshake/i3status-rust")
(synopsis "i3status, written in pure Rust")
(description "@code{i3status-rs} is a feature-rich and resource-friendly
@@ -1051,6 +1081,41 @@ show number of files, total lines within those files and code, comments, and
blanks grouped by language.")
(license (list license:expat license:asl2.0))))
+(define-public vivid
+ (package
+ (name "vivid")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "vivid" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "01fds6dm19bqgqydaa6n051v9l4wh9rb5d6sr9akwp2cc0fs43b7"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-ansi-colours" ,rust-ansi-colours-1)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-dirs" ,rust-dirs-3)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-rust-embed" ,rust-rust-embed-5)
+ ("rust-yaml-rust" ,rust-yaml-rust-0.4))))
+ (home-page "https://github.com/sharkdp/vivid")
+ (synopsis "LS_COLORS environment variable manager")
+ (description
+ "vivid is a generator for the @code{LS_COLORS} environment variable that
+controls the colorized output of ls, tree, fd, bfs, dust and many other tools.
+
+It uses a YAML configuration format for the filetype-database and the color
+themes. In contrast to @command{dircolors}, the database and the themes are
+organized in different files. This allows users to choose and customize color
+themes independent from the collection of file extensions. Instead of using
+cryptic ANSI escape codes, colors can be specified in the RRGGBB format and
+will be translated to either truecolor (24-bit) ANSI codes or 8-bit codes for
+older terminal emulators.")
+ (license (list license:expat license:asl2.0))))
+
(define-public watchexec
(package
(name "watchexec")