summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorGabriel Arazas <foo.dogsquared@gmail.com>2020-09-10 19:27:31 +0800
committerEfraim Flashner <efraim@flashner.co.il>2020-09-11 14:26:06 +0300
commit0a2e80c369d4beb2073d9d604611fefbf268740d (patch)
treef5a857a9736ada4154747a1e2bf355d99bd1b46b /gnu/packages/rust-apps.scm
parent76c18f880c3ee9bde9540e44440f5a2e1dfd4180 (diff)
downloadguix-patches-0a2e80c369d4beb2073d9d604611fefbf268740d.tar
guix-patches-0a2e80c369d4beb2073d9d604611fefbf268740d.tar.gz
gnu: Add hexyl.
* gnu/packages/rust-apps.scm (hexyl): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 76be9acad1..0700167521 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2020 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -205,6 +206,34 @@ While it does not seek to mirror all of find's powerful functionality, it
provides defaults for 80% of the use cases.")
(license (list license:expat license:asl2.0))))
+(define-public hexyl
+ (package
+ (name "hexyl")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hexyl" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0sipag77196467idbznbk5q5lwhqz85zw7y1pwg9b27jxqyk04rp"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-ansi-term" ,rust-ansi-term-0.12)
+ ("rust-atty" ,rust-atty-0.2)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-libc" ,rust-libc-0.2))))
+ (home-page "https://github.com/sharkdp/hexyl")
+ (synopsis "Command-line hex viewer")
+ (description
+ "This package provides a command line hex viewer. It uses a colored output
+for distinguishing different kinds of bytes such as NULL bytes, printable ASCII
+characters, ASCII whitespace characters, other ASCII characters and non-ASCII.")
+ (license (list license:expat license:asl2.0))))
+
(define-public ripgrep
(package
(name "ripgrep")