summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-13 12:00:24 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-17 23:01:28 -0400
commitf949b60e69601fa9965f517ef2de0b7546331844 (patch)
tree2c54351e638ed8412596333ecfffa2cee54236b3 /gnu/packages/ruby.scm
parentce52f2b11cb1033e74efe9bb2178fa6667dffff3 (diff)
downloadguix-patches-f949b60e69601fa9965f517ef2de0b7546331844.tar
guix-patches-f949b60e69601fa9965f517ef2de0b7546331844.tar.gz
gnu: Add ruby-polyglot.
* gnu/packages/ruby.scm (ruby-polyglot): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9a5b488029..15a26ef91e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1290,6 +1290,26 @@ of its many longstanding issues.")
(home-page "https://github.com/prawnpdf/prawn-templates")
(license %prawn-project-licenses)))
+(define-public ruby-polyglot
+ (package
+ (name "ruby-polyglot")
+ (version "0.3.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "polyglot" version))
+ (sha256
+ (base32
+ "1bqnxwyip623d8pr29rg6m8r0hdg08fpr2yb74f46rn1wgsnxmjr"))))
+ (build-system ruby-build-system)
+ (arguments `(#:tests? #f)) ;no test suite
+ (synopsis "Augment @code{require} to load non-Ruby file types")
+ (description "The Polyglot library allows a Ruby module to register a
+loader for the file type associated with a filename extension, and it augments
+@code{require} to find and load matching files.")
+ (home-page "https://github.com/cjheath/polyglot")
+ (license license:expat)))
+
(define-public ruby-ast
(package
(name "ruby-ast")