summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-08 22:22:29 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-08 22:22:29 -0400
commitf9083965293117994c56715f0de89ca98a95b81a (patch)
treea3ece97337901725df6e6322c09eefd3a1c93c47 /gnu/packages/ruby.scm
parent1097fdbea75c2e9cc7c8a72c50a812def6ce62e6 (diff)
downloadguix-patches-f9083965293117994c56715f0de89ca98a95b81a.tar
guix-patches-f9083965293117994c56715f0de89ca98a95b81a.tar.gz
gnu: Add ruby-cuke-modeler.
* gnu/packages/ruby.scm (ruby-cuke-modeler): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 172dd4fe60..2e4ca7b284 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4226,6 +4226,32 @@ for select languages.")
(home-page "http://coderay.rubychan.de")
(license license:expat)))
+(define-public ruby-cuke-modeler
+ (package
+ (name "ruby-cuke-modeler")
+ (version "3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "cuke_modeler" version))
+ (sha256
+ (base32
+ "19smj3g3wvz0203l549sadpcxgh0ir350a6k78gq0bmlv9cchmjb"))))
+ (build-system ruby-build-system)
+ (arguments `(#:tests? #f)) ;no test suite in gem
+ (propagated-inputs
+ `(("ruby-gherkin" ,ruby-gherkin)))
+ (synopsis "Gherkin test suite analysis tool")
+ (description "CukeModeler facilitates modeling a test suite that is
+written in Gherkin (e.g. Cucumber, SpecFlow, Lettuce, etc.). It does this by
+providing an abstraction layer on top of the Abstract Syntax Tree (AST) that
+the @code{cucumber-gherkin} generates when parsing features, as well as
+providing models for feature files and directories in order to be able to have
+a fully traversable model tree of a test suite's structure. These models can
+then be analyzed or manipulated more easily than the underlying AST layer.")
+ (home-page "https://github.com/enkessler/cuke_modeler")
+ (license license:expat)))
+
(define-public ruby-parallel-tests
(package
(name "ruby-parallel-tests")