summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-01-13 19:58:22 +0000
committerChristopher Baines <mail@cbaines.net>2020-01-14 23:40:46 +0000
commitf321380fb3fa5921dcbe77df4329af8b242a2dcb (patch)
tree770e3c2b33dab36a96b1e0f24feb600b33c92e7d /gnu/packages/ruby.scm
parent459e4a1aa184ad863eec4374ca7683de92b4aa06 (diff)
downloadguix-patches-f321380fb3fa5921dcbe77df4329af8b242a2dcb.tar
guix-patches-f321380fb3fa5921dcbe77df4329af8b242a2dcb.tar.gz
gnu: ruby-yard: Update to 0.9.20.
* gnu/packages/ruby.scm (ruby-yard): Update to 0.9.20. [arguments]: Delete the Gemfile before running the tests. [native-inputs]: Add ruby-redcloth and ruby-asciidoctor.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 140d9f5fd2..eec20b088f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5783,7 +5783,7 @@ A modified copy of yajl is used, and included in the package.")
(define-public ruby-yard
(package
(name "ruby-yard")
- (version "0.9.16")
+ (version "0.9.20")
(source
(origin
(method git-fetch)
@@ -5794,20 +5794,24 @@ A modified copy of yajl is used, and included in the package.")
(file-name (git-file-name name version))
(sha256
(base32
- "0a4r1pfs0ms4vlccsf1x2jckx35lqm8b8lh6rdjxqfr5fia5izpf"))))
+ "1v48zz8hzazrg79jksj9siys21d2axvzijvkxw2j42zh86syi1wi"))))
(build-system ruby-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda _
+ ;; Delete the Gemfile to avoid errors relating to it
+ (delete-file "Gemfile")
;; $HOME needs to be set to somewhere writeable for tests to run
(setenv "HOME" "/tmp")
;; Run tests without using 'rake' to avoid dependencies.
(invoke "rspec"))))))
(native-inputs
`(("ruby-rspec" ,ruby-rspec)
- ("ruby-rack" ,ruby-rack)))
+ ("ruby-rack" ,ruby-rack)
+ ("ruby-redcloth" ,ruby-redcloth)
+ ("ruby-asciidoc" ,ruby-asciidoctor)))
(synopsis "Documentation generation tool for Ruby")
(description
"YARD is a documentation generation tool for the Ruby programming